<!DOCTYPE html>
<html lang="en">
<head>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"a2134792db","applicationID":"36240457","transactionName":"dApeRxcOWV5RFB1SA0QORFwVTlBcQBRbUxUYFlhcEg==","queueTime":1,"applicationTime":21,"agent":"","atts":"TEdFEV8aF1dQD0ZfCVlHChEQEhceFhVXVRJeCl4RX0NwXEADQEIHXgtdVgsVF09J"}</script>
<script type="text/javascript">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</script>
<meta content="97Mj-wW7u8U1NOnkW1rfH-I1kgO0-a9YsgoesOk41R8" name="google-site-verification">
<meta content="false" name="oath:guce:product-eu">
<meta content="guce.huffpost.com" name="oath:guce:consent-host">
<meta content="en-US" name="oath:guce:locale">
<meta content="true" name="oath:guce:inline-consent">
<script async="true" src="https://s.yimg.com/oa/guce.js" type="text/javascript"></script>
<script async src="https://consent.cmp.oath.com/cmp.js" type="text/javascript"></script>
<script id="gdpr-cmp-stub">
!function(e){var t={};function n(r){if(t[r])return t[r].exports;var a=t[r]={i:r,l:!1,exports:{}};return e[r].call(a.exports,a,a.exports,n),a.l=!0,a.exports}n.m=e,n.c=t,n.d=function(e,t,r){n.o(e,t)||Object.defineProperty(e,t,{enumerable:!0,get:r})},n.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},n.t=function(e,t){if(1&t&&(e=n(e)),8&t)return e;if(4&t&&"object"==typeof e&&e&&e.__esModule)return e;var r=Object.create(null);if(n.r(r),Object.defineProperty(r,"default",{enumerable:!0,value:e}),2&t&&"string"!=typeof e)for(var a in e)n.d(r,a,function(t){return e[t]}.bind(null,a));return r},n.n=function(e){var t=e&&e.__esModule?function(){return e.default}:function(){return e};return n.d(t,"a",t),t},n.o=function(e,t){return Object.prototype.hasOwnProperty.call(e,t)},n.p="/",n(n.s=16)}({16:function(e,t,n){"use strict";n.r(t),n(17),function(){function e(e){var t,n="string"==typeof e.data,r=e.data;if(n)try{r=JSON.parse(e.data)}catch(r){}r&&r.__cmpCall&&(t=r.__cmpCall,window.__cmp(t.command,t.parameter,(function(r,a){var o={__cmpReturn:{returnValue:r,success:a,callId:t.callId}};e&&e.source&&e.source.postMessage(n?JSON.stringify(o):o,"*")})))}window.document.documentMode||n(18),"function"==typeof __cmp||(window.__cmp=function(){var e=arguments;if(__cmp.a=__cmp.a||[],!e.length)return __cmp.a;"ping"===e[0]?e[2]({gdprAppliesGlobally:!1,cmpLoaded:!1},!0):__cmp.a.push([].slice.apply(e))},function e(){if(document.body&&document.body.firstChild){var t=document.body,n=document.createElement("iframe");n.style.display="none",n.height=n.width=0,n.name="__cmpLocator",t.insertBefore(n,t.firstChild)}else setTimeout(e,5)}(),window.addEventListener?window.addEventListener("message",e,!1):window.attachEvent("onmessage",e))}()},17:function(e,t){!function(){for(var e,t="__uspapiLocator",n=[],r=window;r;){try{if(r.frames[t]){e=r;break}}catch(e){}if(r===window.top)break;r=r.parent}e||(function e(){var n=r.document;if(!r.frames[t])if(n.body){var a=n.createElement("iframe");a.style.cssText="display:none",a.name=t,n.body.appendChild(a)}else setTimeout(e,5)}(),r.__uspapi=function(){for(var e=arguments.length,t=new Array(e),r=0;r<e;r++)t[r]=arguments[r];if(!t.length)return n;n.push(t)},r.addEventListener("message",(function(e){var t="string"==typeof e.data,n={};try{n=t?JSON.parse(e.data):e.data}catch(n){}var r=n.__uspapiCall;r&&window.__uspapi(r.command,r.version,(function(n,a){var o={__uspapiReturn:{returnValue:n,success:a,callId:r.callId}};t&&(o=JSON.stringify(o)),e.source.postMessage(o,"*")}),r.parameter)}),!1))}()},18:function(e,t,n){"use strict";n.r(t);var r=n(9);n.n(r)()()},9:function(e,t,n){"use strict";e.exports=function(){for(var e,t="__tcfapiLocator",n=[],r=window;r;){try{if(r.frames[t]){e=r;break}}catch(e){}if(r===window.top)break;r=r.parent}e||(function e(){var n=r.document,a=!!r.frames[t];if(!a)if(n.body){var o=n.createElement("iframe");o.style.cssText="display:none",o.name=t,n.body.appendChild(o)}else setTimeout(e,5);return!a}(),r.__tcfapi=function(){for(var e,t=arguments.length,r=new Array(t),a=0;a<t;a++)r[a]=arguments[a];if(!r.length)return n;if("setGdprApplies"===r[0])3<r.length&&2===parseInt(r[1],10)&&"boolean"==typeof r[3]&&(e=r[3],"function"==typeof r[2]&&r[2]("set",!0));else if("ping"===r[0]){var o={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof r[2]&&r[2](o)}else n.push(r)},r.addEventListener("message",(function(e){var t="string"==typeof e.data,n={};try{n=t?JSON.parse(e.data):e.data}catch(e){}var r=n.__tcfapiCall;r&&window.__tcfapi(r.command,r.version,(function(n,a){var o={__tcfapiReturn:{returnValue:n,success:a,callId:r.callId}};t&&(o=JSON.stringify(o)),e.source.postMessage(o,"*")}),r.parameter)}),!1))}}});
window.__cmp('init', { isOathFirstParty: true });
</script>
<script async src="https://s.yimg.com/oa/consent.js" type="text/javascript"></script>

<script>
  // critical desktop
  window.HP=window.HP||{},HP.modules=HP.modules||{},HP.functions=HP.functions||{},HP.elements=HP.elements||{},HP.params=HP.params||{},HP.modules.ads={banner:"",square:"",promotion:""},window.HP.functions.isEmpty=function(n){for(var t in n)if(n.hasOwnProperty(t))return!1;return!0},window.MW=HP,window.Mobileweb=HP.modules,function(n){var e=function(n,t){var e=new RegExp("[?&]"+t+"(=(.*?))?(&|$)","i"),r=n.match(e);if(r)return r[2]||""},t=function(n,t){return void 0!==e(n,t)};n.getQueryStringParameter=e,n.isQueryStringParameterPresent=t}(HP.functions),HP.modules.storage=function(){var n,t,e,r,i,o,a,s,u,d;return o=function(){try{var n="test";return(s=window.localStorage).setItem(n,"1"),s.removeItem(n),!0}catch(t){return!1}}(),d=function(n){if("string"!=typeof n)return undefined;try{return JSON.parse(n)}catch(t){return n||undefined}},u=function(n){return JSON.stringify(n)},a=function(){},o?(t=function(n,t){try{s.setItem(n,u(t))}catch(e){}},e=function(n){s.removeItem(n)},r=function(){s.clear()},i=function(n){return s.getItem(n)!==undefined},(n=function(n){return d(s.getItem(n))})("lastPurge")<=1430758101108&&(r(),t("lastPurge",Date.now()))):(n=t=e=r=a,i=function(){return!1}),{enabled:o,get:n,set:t,remove:e,clear:r,has:i}}(),function(){function a(n){var t="",e=window.location.href,r=window.HP.functions.getQueryStringParameter(window.location.href,"ab"),i=window.HP.functions.getQueryStringParameter(window.location.href,"g");return r===undefined||i===undefined||r!==n||-1===e.indexOf("staging")&&-1===e.indexOf("local")&&-1===e.indexOf("design")||f[r]&&f[r].variants[i]&&(t=i),t}function s(n,t){if(f[n]){var e=f[n].id,r=f[n].variants[t];r===undefined&&console.error("Could not find AB test variant for value",t),d(n,e,t,r)}else console.error("Could not find AB test",n)}function u(n){var t=Object.keys(f[n].variants),e=f[n].distribution;return e?r(t,e):t[Math.floor(Math.random()*t.length)]}function r(n,t){for(var e=0,r=Math.random(),i=0;i<n.length;i++)if(r<=(e=+(e+=t[i]).toFixed(2)))return n[i]}function e(n){if(localStorage.getItem("abTest-"+n))return JSON.parse(localStorage.getItem("abTest-"+n)).value}function i(n,t){g[n]=t;var e=localStorage["abTest-"+n];(void 0===e||e.date+w<Date.now())&&m.set("abTest-"+n,{value:t,date:Date.now()})}function o(n){var t=e(n);return t===undefined&&i(n,t=u(n)),t}function d(n,t,e,r){c.push([t,r].join(":")),l.push([n,e].join(":")),i(n,e),window.HP.devMode&&console.log("AB test",n,"set to",e)}var f={},c=[],l=[],m=window.HP.modules.storage,g={};window.HP.modules.AB={set:s,testMap:function(){return c},userGroupTestMap:function(){return Object.keys(f).map(function(n){var t=f[n].id,e=f[n].variants[o(n)];if(t!==undefined&&e!==undefined)return t+":"+e})},namedTestMap:function(){return l},registerTest:function(n,t,e,r){if(!((r=r||{}).platforms&&-1===r.platforms.indexOf(HP.params.device)||r.editions&&-1===r.editions.indexOf(HP.params.edition.id)))return f[n]={id:t,variants:e},r.distribution&&(f[n].distribution=r.distribution),f[n]},sample:function(n,t){if(!f[n])return undefined;var e=t;if(g[n])return g[n];var r=a(n);if(""!==r)e=r;else if(m.enabled||t===undefined){var i="abTest-"+n,o=m.get(i);e=o&&Date.now()<o.date+w?o.value:u(n)}return s(n,e),e},sampleAnonymous:function(n,t){var e="anonymous-"+n;if(g[e])return g[e];var r=t[Math.floor(Math.random()*t.length)];if(m.enabled){var i="abTest-"+e,o=m.get(i);o&&Date.now()<o.date+w&&(r=parseInt(o.value,10))}return d(e,n,r,r),r}};var w=6048e5,v=HP.modules.AB;HP.params&&HP.params.ab_config&&HP.params.ab_config.forEach(function(n){var e={},r=n.variant_ids.split(","),t=n.variant_distributions.split(",").map(function(n){return parseFloat(n)});n.variant_names.split(",").forEach(function(n,t){e[n]=parseInt(r[t])}),v.registerTest(n.name,parseInt(n.id),e,{distribution:t})})}(),function(){var n=window.HP.modules.AB;n.registerTest("appDownloadEntryInterstitial-2",1037,{firstToKnow:109,storiesThatMatter:110}),n.registerTest("appDownloadModalFrontAndroid2",1041,{hide:121,showEntertainmentVerticalImage:122},{distribution:[.85,.15]}),n.registerTest("appDownloadModalFrontiOS2",1042,{hide:124,showEntertainmentVerticalImage:125},{distribution:[.85,.15]}),n.registerTest("slideshowCard",1036,{control:106,overlay:107,grid:108}),n.registerTest("huffpostPlusMidEntryCta3",1049,{a:142,b:143,c:144})}();
</script>
<script src="https://s.yimg.com/ss/rapid3.js" type="text/javascript"></script>
<script>
  window.rapidConfig = {"spaceid":"1197803116","async_all_clicks":true,"tracked_mods":[],"nonanchor_track_class":"yr-track","accountGUID":null,"test_id":"content_progression_control","rapid_noclick_resp":"yr-no-track","keys":{"st_sec":"us.hpmgent","pt":"content","pct":"story","paid":"the_huffington_post_584=hpo:5ec31ec4c5b6b973546ff05e","ver":"huffpostcms","p_sec":"entertainment","p_subsec":"entertainment","pstaid":"51649bce-4605-321f-bf4f-b0613a5872de","layout":"default","pl4":"none","pl1":"none"}};
  (function(){
    var AB = window.HP.modules.AB;
    window.rapidConfig.keys['pl3'] = AB.testMap();
  }());
  window.RapidInstance = new window.YAHOO.i13n.Rapid(window.rapidConfig);
</script>

<meta content="18468761129" property="fb:pages">
<meta content="56845382910" property="fb:pages">
<meta content="115699328440194" property="fb:pages">
<meta content="202163013203224" property="fb:pages">
<meta content="63096571313" property="fb:pages">
<meta content="217254191630265" property="fb:pages">
<meta content="70072372362" property="fb:pages">
<meta content="10018702564" property="fb:pages">
<meta content="159156871082" property="fb:pages">
<meta content="218821728150273" property="fb:pages">
<meta content="215547491837032" property="fb:pages">
<meta content="271573749521209" property="fb:pages">
<meta content="256004367748633" property="fb:pages">
<meta content="565494996987624" property="fb:pages">
<meta content="328537730839840" property="fb:pages">
<meta content="335527613514005" property="fb:pages">
<meta content="928754893893780" property="fb:pages">
<meta content="1254930621269234" property="fb:pages">
<meta content="1242860892501019" property="fb:pages">
<meta content="131149920304237" property="fb:pages">
<meta content="70242384902" property="fb:pages">
<meta content="max-image-preview:large" name="robots">

<title>&#39;Twilight&#39; Actor Gregory Tyree Boyce Dead At 30 | HuffPost</title>
<meta charset="utf-8">
<meta content="width=device-width, initial-scale=1.0, minimum-scale=1.0" name="viewport">
<meta content="Boyce was best known for his role as Tyler Crowley in &quot;Twilight.&quot;" name="description">
<meta content=" obit,Twilight  film,Gregory Tyree Boyce" name="keywords">
<meta content="&#39;Twilight&#39; Actor Gregory Tyree Boyce Dead At 30" property="og:title">
<meta content="article" property="og:type">
<meta content="https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&amp;ops=1778_1000" property="og:image">
<meta content="https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&amp;ops=1778_1000" property="og:image:url">
<meta content="image/jpeg" property="og:image:type">
<meta content="1778" property="og:image:width">
<meta content="1000" property="og:image:height">
<meta content="https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" property="og:url">
<meta content="HuffPost" property="og:site_name">
<meta content="en_US" property="og:locale">
<meta content="Boyce was best known for his role as Tyler Crowley in &quot;Twilight.&quot;" property="og:description">
<meta content=" obit,Twilight  film,Gregory Tyree Boyce" property="article:tag">
<meta content="Entertainment" property="article:section">
<meta content="summary_large_image" name="twitter:card">
<meta content="@HuffPostEnt" name="twitter:site">
<meta content="&#39;Twilight&#39; Actor Gregory Tyree Boyce Dead At 30" property="twitter:title">
<meta content="https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&amp;ops=1778_1000" property="twitter:image">
<meta content="1778" property="twitter:image:width">
<meta content="1000" property="twitter:image:height">
<meta content="Boyce was best known for his role as Tyler Crowley in &quot;Twilight.&quot;" property="twitter:description">
<meta content="@JosieHarvey_" property="twitter:creator">
<meta content="2020-05-18 20:34:44 -0400" property="article:published_time">
<meta content="2020-05-18 20:42:43 -0400" property="article:modified_time">
<meta content="huffpostnews:///?editionID=us&amp;entryID=us_5ec31ec4c5b6b973546ff05e" property="al:ios:url">
<meta content="306621789" property="al:ios:app_store_id">
<meta content="HuffPost" property="al:ios:app_name">
<link href="ios-app://306621789/huffpostnews/?editionID=us&amp;entryID=us_5ec31ec4c5b6b973546ff05e" rel="alternate">

<meta content="46744042133" property="fb:app_id">
<meta content="text/html" http-equiv="Content-Type">
<meta content="IE=Edge,chrome=1" http-equiv="X-UA-Compatible">
<link href="/opensearch.xml" rel="search" type="application/opensearchdescription+xml">
<link rel="shortcut icon" type="image/x-icon" href="https://s.m.huffpost.com/assets/favicon-2020e123c064086aad150fe909c53771f862d7c76cd62f6146e81d533845fd7d.ico" />
<link href="//m.huffpost.com/us/entry/us_5ec31ec4c5b6b973546ff05e" media="handheld" rel="alternate">
<link href="//m.huffpost.com/us/entry/us_5ec31ec4c5b6b973546ff05e" media="only screen and (max-width: 640px)" rel="alternate">
<link href="https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" rel="canonical">
<link href="https://m.huffpost.com/us/entry/us_5ec31ec4c5b6b973546ff05e/amp" rel="amphtml">
<style>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</style>
<link href="https://fonts.googleapis.com/css?family=Montserrat:700,800,800i" rel="stylesheet">
<script>
  (function(){
    window.HP || (window.HP = {});
    HP.params = {"device":"desktop","edition":{"id":"us"},"ab_config":[{"name":"homepageSplash","id":1008,"variant_names":"control,splash","variant_ids":"26,27","variant_distributions":"0.5,0.5"},{"name":"outstreamStyle","id":1002,"variant_names":"control,enabled","variant_ids":"11,12","variant_distributions":"0.75,0.25"},{"name":"outstreamParents","id":1001,"variant_names":"control,enabled","variant_ids":"9,10","variant_distributions":"0.75,0.25"},{"name":"outstreamPolitics","id":1000,"variant_names":"control,enabled","variant_ids":"7,8","variant_distributions":"0.75,0.25"},{"name":"videoBelowSplash100Percent","id":92,"variant_names":"video","variant_ids":"138","variant_distributions":"1.0"},{"name":"vidibleOnHomepage2","id":91,"variant_names":"noVideo,autoPlayWithoutSound","variant_ids":"136,137","variant_distributions":"0.8,0.2"},{"name":"mfp1829","id":1010,"variant_names":"embed,embedFlip,autoPlayWithoutSound","variant_ids":"31,32,33","variant_distributions":"0.4,0.4,0.2"}],"staging":false};
  
    var userGuid = '{{__HP-USER-GUID__}}'.replace(/\{\{__HP[-]USER[-]GUID__\}\}/, '');
    var userEmail = '{{__HP-USER-EMAIL__}}'.replace(/\{\{__HP[-]USER[-]EMAIL__\}\}/, '');
    var userRoles = '{{__HP-USER-ROLES__}}'.replace(/\{\{__HP[-]USER[-]ROLES__\}\}/, '');
    var csrfToken = '{{__HP-CSRF-TOKEN__}}'.replace(/\{\{__HP[-]CSRF[-]TOKEN__\}\}/, '');
    HP.params.userGuid = userGuid ? userGuid : null;
    HP.params.userEmail = userEmail ? userEmail : null;
    HP.params.csrfToken = csrfToken ? csrfToken : null;
    HP.params.userRoles = userRoles && userRoles.length ? userRoles.split(',') : [];
  }());
</script>

<script>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</script>
<script>
  window.HP.functions.loadFont('ProximaNovaCond', 'https://s.m.huffpost.com/assets/fonts/proxima-nova-condensed-00413bf3c406df7a1c9b6218d92f311ced4bc12564bede72e457e7963bf16f44.css', {
    before: "h1,h2,h3,h4,h5{visibility:hidden;}",
    after: "h1,h2,h3,h4,h5{visibility:visible;}"
  }, 1000);
</script>
<script>
  window.HP.functions.loadFont('ProximaNova', 'https://s.m.huffpost.com/assets/fonts/proxima-nova-8436d7ce85f4132d9836303fd5f328b5132418284edeaa238f9d6a54bf8a767c.css', {
    before: "h1,h2,h3,h4,h5{visibility:hidden;}",
    after: "h1,h2,h3,h4,h5{visibility:visible;}"
  }, 500);
</script>

<script type="application/ld+json">
{"@type":"NewsArticle","articleSection":"Entertainment","speakable":{"@type":"SpeakableSpecification","cssSelector":[".headline__title",".headline__subtitle",".js-entry-text"]},"@context":"http://schema.org","dateCreated":"2020-05-19T00:34:44Z","datePublished":"2020-05-19T00:34:44Z","dateModified":"2020-05-19T00:42:43Z","author":{"@context":"http://schema.org","@type":"Person","affiliation":{"@type":"NewsMediaOrganization","name":"HuffPost","url":"https://www.huffpost.com","logo":{"@type":"ImageObject","url":"https://s.m.huffpost.com/assets/hp-amp-101ecf8047b044dce5f3122c63056162580f1c26994c73ae90dbd1c5d1545a71.gif","width":600,"height":60}},"name":"Josephine Harvey","jobTitle":"Trends Reporter, HuffPost","description":"Josephine Harvey is a trends reporter at HuffPost, based in Sydney.","url":"https://www.huffpost.com/author/josie-harvey"},"creator":{"@context":"http://schema.org","@type":"Person","affiliation":{"@type":"NewsMediaOrganization","name":"HuffPost","url":"https://www.huffpost.com","logo":{"@type":"ImageObject","url":"https://s.m.huffpost.com/assets/hp-amp-101ecf8047b044dce5f3122c63056162580f1c26994c73ae90dbd1c5d1545a71.gif","width":600,"height":60}},"name":"Josephine Harvey","jobTitle":"Trends Reporter, HuffPost","description":"Josephine Harvey is a trends reporter at HuffPost, based in Sydney.","url":"https://www.huffpost.com/author/josie-harvey"},"publisher":{"@type":"NewsMediaOrganization","name":"HuffPost","url":"https://www.huffpost.com","logo":{"@type":"ImageObject","url":"https://s.m.huffpost.com/assets/hp-amp-101ecf8047b044dce5f3122c63056162580f1c26994c73ae90dbd1c5d1545a71.gif","width":600,"height":60}},"description":"Boyce was best known for his role as Tyler Crowley in \"Twilight.\"","keywords":["obit","twilight-film","gregory-tyree-boyce","@team_us_huffpost_now","type: news"],"inLanguage":"en_US","thumbnailUrl":"https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&ops=200_150","url":"https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e","headline":"'Twilight' Actor Gregory Tyree Boyce Dead At 30","image":{"@type":"ImageObject","url":"https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&ops=1778_1000","width":1778,"height":1000},"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e"}}

</script>
<!--__HP-SPOT-SCHEMA__-->

<script>
  window.__logAtwola = "https://ads-debug.huffpost.com:4443";
</script>
<!-- Ad Header -->
<style type="text/css">
.pg-placeholder.active {
  margin: 20px 0;
  padding: 20px 0;
  border-style: solid;
  border-color: #000;
  border-width: 1px 0;
}
</style>
<script type="text/javascript">
waitForGlobal(function(){
  var div = document.getElementById("entry-footer");
  return !!div;
}, function() {
  var isLife = document.body.className.match(/life/) !== null;
  var placeholder = document.createElement('div');
  var hideCallback = function() {
    console.log('PG: no campaign match');
  };
  var showCallback;
  var nodes;
  placeholder.className = "pg-placeholder";
  placeholder.setAttribute('id', 'public-good-placeholder');
  if ( isLife ) {
    nodes = document.querySelectorAll(".js-main-content-list div.cli");
    showCallback = function() {
      console.log('PG: callback on Life article');
      //var div = document.querySelector("section.js-entry-content section.newsletter");
      //div.innerHTML = "";
      //document.getElementById('public-good-placeholder').className = 'pg-placeholder active';
    };
  } else {
    nodes = document.querySelectorAll(".js-entry-text div.content-list-component");
    callback = function() {
      console.log('PG: callback on News article');
      //var div = document.querySelector("section.js-entry-inline-subscription-module");
      //div.innerHTML = "";
      //document.getElementById('public-good-placeholder').className = 'pg-placeholder active';
    };
  }
  var targetDiv = nodes[nodes.length - 1];
  if ( !targetDiv || !targetDiv.parentNode ) {
    console.log('PG: could not find last CLI');
  } else {
    targetDiv.parentNode.insertBefore(placeholder, targetDiv.nextSibling);
    var pgmOptions = {
      partnerId: "verizon-huffpost",
      onShow: function() {
        console.log('PG: show callback fired');
        showCallback();
      },
      onHide: function() {
        console.log('PG: hide callback fired');
        hideCallback();
      }
    };
    var script = document.createElement('script');
    script.async = true;
    script.onload = function() {
      pgmApi.create(document.getElementById("public-good-placeholder"), pgmOptions);
    };
    script.src = "https://assets.publicgood.com/pgm/v1/pgm-api.js";
    console.log('PG: loading PG scripts');
    document.head.appendChild(script);
  }
});
</script>
<!-- begin yahoo flurry header bootstrap -->
<script type="text/javascript">
window.__yahooFlurry = {
  registry: [],
  complete: [],
  remove: {},
  original: {},
  timeout: null,
  cleanupCount: 0,
  register: function(code) {
    this.registry.push(code);
  },
  ready: function(code) {
    this.complete.push(code);
  },
  isReady: function() {
    return this.registry.length === this.complete.length && this.registry.length > 0;
  },
  addToCleanup: function(code, div, originalHtml) {
    this.remove[code] = div;
    this.original[code] = originalHtml;
  },
  cleanup: function() {
    var _this = this;
    this.cleanupCount = this.cleanupCount + 1;
    console.log("cleanup attempt #" + this.cleanupCount.toString());
    this.timeout = setTimeout(function(){
      for ( var i in _this.remove ) {
        if ( _this.remove.hasOwnProperty(i) ) {
          if ( window.jQuery("[code=" + i + "]").length > 0 ) {
            window.jQuery("#" + _this.remove[i]).remove();
            console.log(_this.remove[i]);
            delete _this.remove[i];
          }
        }
      }
      if ( Object.keys(_this.remove).length ) {
        if ( _this.cleanupCount < 50 ) {
          _this.cleanup();
        } else if ( _this.cleanupCount >= 50 ) {
          _this.restoreOriginals();
        }
      }
    }, 100);
  },
  restoreOriginals: function() {
    console.log("restoring");
    console.log(this.remove);
    console.log(this.original);
    for ( var i in this.remove ) {
      if ( this.remove.hasOwnProperty(i) ) {
        var $original = $(this.original[i]);
        $original.insertBefore("#" + this.remove[i]);
        window.jQuery("#" + this.remove[i]).remove();
      }
    }
  }
};
</script>
<script type="text/javascript">
window.adTechCallback = function() {
  
  
  window.adSetAdURL(location.protocol + '//' + (document.domain || 'www.huffingtonpost.com') + (location.port?':'+location.port:'') + '/_uac/2014adpage.html');
  window.tacProp={tags:"kvcategory=entertainment;kvpagetype=atf:bpage:news:standard;kventryid=5ec31ec4c5b6b973546ff05e;kvpubmarket=us;kvcmsid=hpo:5ec31ec4c5b6b973546ff05e;kveditags=gregory-tyree-boyce:obit:twilight-film;kvpublisher=huffpost;kvvert=entertainment;kvblogger=josie-harvey"};
  
  window.tacProp.tags += ( (typeof window.HPAds!=="undefined") && (typeof window.HPAds.adtech_client_side_inf=="function") ) ? window.HPAds.adtech_client_side_inf() : "";
  //window.tacProp.tags += ";kvrefd="+document.referrer;
  if (typeof window.adSetOthAT=="function") window.adSetOthAT(window.tacProp.tags);
  
  window.adSetMOAT('1');
  
  try {
    window.adsEnableSandbox();
    console.info('adsEnableSandbox on');
  } catch (_) {
    console.warn('adsEnableSandbox not supported');
  }
};
</script>

<script src="https://o.aolcdn.com/ads/adsWrapper.js" async></script>
<script type="text/javascript">

  
  
  
  window.waitForGlobal('adSetAdURL', function(){
  
    window.adTechCallback();
  
  });
  
</script>

<meta name="taboola.category" content="entertainment" />
<script type="text/javascript">
window.adSetSyncCalled = false;
waitForGlobal('adSetSyncDelay', function() {
  adSetSyncDelay('50');
  window.adSetSyncCalled = true;
});
var _uacModuleDebug = function(m){
  try {
    var w = window;
    var key = 'debugUAC';
    var str = w.location.search;
    var f =  decodeURIComponent(str.replace(new RegExp("^(?:.*[&\\?]" + encodeURIComponent(key).replace(/[\.\+\*]/g, "\\$&") + "(?:\\=([^&]*))?)?.*$", "i"), "$1")).replace(/(^\s+|\s+$)/g, "") || null;
    if (f == 1) {
      return w.console && w.console.debug('[UAC] > ' + m); 
    }
  } catch (err) { }
  return;
};
</script>

<script type="text/javascript">
    function doTaboola(taboolaParams) {
        if (typeof taboolaParams == 'undefined') return;
        
        window._taboola = window._taboola || [];
        if (!doTaboola.loaded) {
            _taboola.push({ article:'auto' });
            var _async_script = !function (e, f, u) {
                e.async = 1;
                e.src = u;
                f.parentNode.insertBefore(e, f);
            }(document.createElement('script'), document.getElementsByTagName('script')[0], taboolaParams.loader);
            doTaboola.loaded = true;
        }
        window.__taboolaRecircCount = { "native": 0, "taboola": 0 };
        window.__taboolaModulesAdded = false;
        _taboola.push({
            "listenTo": 'render',
            "handler": function(e) {
                var detail = e.detail;
                if ( detail.mode.substr(0,7) === "organic" ) {
                  var type = "native";
                } else {
                  var type = "taboola";
                }
                var i = 0;
                var container = window.jQuery(detail.container);
                while ( window.jQuery && detail.items[i] ) {
                    var curCount = window.__taboolaRecircCount[type];
                    curCount++;
                    window.__taboolaRecircCount[type] = curCount;
                    var imageSlk = "elm:img;subsec:" + type + ";cpos:" + curCount + ";pos:1";
                    var headlineSlk = "elm:hdln;subsec:" + type + ";cpos:" + curCount + ";pos:2";
                    var dataItemId = detail.items[i].id;
                    var taboolaDomNode = container.find(".videoCube_" + (i+1).toString() + "_child");
                    taboolaDomNode.find(".item-thumbnail-href").attr("data-ylk", imageSlk); 
                    taboolaDomNode.find(".item-label-href").attr("data-ylk", headlineSlk);
                    i++;
                }
                if ( window.RapidInstance ) {
                  if ( !window.__taboolaModulesAdded ) {
                    window.RapidInstance.addModules(['below-entry-desktop', 'taboola-below-entry-common']);
                    window.__taboolaModulesAdded = true;
                  }
                  
                  window.RapidInstance.refreshModule("below-entry-desktop");
                  
                  window.RapidInstance.refreshModule("taboola-below-entry-common");
                }
            }
        });
        var cb = function(o){}; // function(o){ o.container.removeAttribute('id'); }
        _taboola.push({onrender: cb, mode:taboolaParams.mode, container:taboolaParams.container, placement:taboolaParams.placement, target_type:taboolaParams.target_type});
        
    }
</script>
<style>.trc-auto-size { height: auto !important; }</style>
<script>
var _HPJS = (function (_mod) {
  "use strict";

  _mod.loadJS = function (src, options) {
    var options = options || {};
    var ref = window.document.getElementsByTagName("script")[0];
    var script = window.document.createElement("script");
    script.src = src;
    script.async = options.async;
    script.defer = options.defer;
    ref.parentNode.insertBefore(script, ref);
    return script;
  }

  _mod.loadJSLater = function (url, timeout) {
    var ran = false;
    var loader = function () {
      if (ran) {
        return;
      }
      ran = true;
      _mod.loadJS(url, {async:true});
    }
    window.addEventListener ?
      window.addEventListener("load",loader,false) :
      window.attachEvent && window.attachEvent("onload",loader);
    // in case the load event never fires
    setTimeout(loader, timeout || 15000);
  }

  _mod.waitForGlobal = function(identifier, cb, poll) {
    var test = typeof identifier === "function" ? identifier : function() { return !!window[identifier]; };
    var interval;
    if(test()) {
      cb();
    } else {
      interval = setInterval(function(){
        if(test()) {
          cb();
          clearInterval(interval);
        }
      }, poll || 50);
    }
  };

  return _mod;

}(_HPJS || {}));
</script>
</head>
<body class="sticky-top-nav-only desktop b-page department--entertainment section--entertainment standard" data-locale="en_US">
<div class="body-wrap">
<div id="recaptcha-container"></div>

<div class="advertisement asset_inserts" data-placement="asset_inserts" data-yaft-module="huffpost-asset_inserts">
<script type="text/javascript">
waitForGlobal("adSetMOAT", function() {
  adSetMOAT("1");
});
</script>
</div>



<div class="main">

<!-- Header -->

<div class="left-nav yr-left-nav" role="menu">
<div class="left-nav__body">
<div class="left-nav__top">
<button aria-label="Close Menu" class="left-nav__close yr-track yr-close-hamburger"></button>
<button aria-expanded="false" class="left-nav__editions-menu__toggle js-edition-toggle yr-editions-button yr-track">US Edition</button>
<div class="left-nav__editions-menu js-editions-menu">

<div class="editions-menu editions-menu--leftnav js-editions-menu yr-editions-menu">
<div class="editions-menu__list">
<div class="editions-menu__list__item current">U.S.</div>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Canada" href="https://www.huffingtonpost.ca?country=CA">Canada</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="U.K." href="https://www.huffingtonpost.co.uk?country=UK">U.K.</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Australia" href="https://www.huffingtonpost.com.au?country=AU">Australia</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Brazil" href="https://www.huffpostbrasil.com?country=BR">Brazil</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="España" href="https://www.huffingtonpost.es?country=ES">España</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="France" href="https://www.huffingtonpost.fr?country=FR">France</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Ελλάδα (Greece)" href="https://www.huffingtonpost.gr?country=GR">Ελλάδα (Greece)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="India" href="https://www.huffingtonpost.in?country=IN">India</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Italia" href="https://www.huffingtonpost.it?country=IT">Italia</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="日本 (Japan)" href="https://www.huffingtonpost.jp?country=JP">日本 (Japan)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="한국 (Korea)" href="https://www.huffingtonpost.kr?country=KR">한국 (Korea)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Quebec" href="https://quebec.huffingtonpost.ca?country=QC">Quebec</a>
</div>
</div>

<div aria-label="Close editions menu" class="left-nav__editions-menu__close js-edition-toggle yr-editions-close-button yr-track" role="button">CLOSE</div>
</div>
</div>
<div class="left-nav__search js-search-container">
<form class="left-nav__search__form" action="https://search.huffpost.com/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" /><input aria-label="Search HuffPost" class="left-nav__search-glass" type="submit" value="search">
<input type="text" name="p" id="left-nav-search-input" placeholder="Search HuffPost" class="left-nav__search__form__input" autocomplete="off" aria-label="Enter Search Text" />
</form></div>
<div class="left-nav__menu">
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Coronavirus" data-subsec="coronavirus" href="https://www.huffpost.com/feature/coronavirus" target="_self">Coronavirus</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="News" data-subsec="news" href="https://www.huffpost.com/news/" target="_self">News</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="U.S. News" data-subsec="news" href="https://www.huffpost.com/section/us-news" target="_self">U.S. News</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="World News" data-subsec="news" href="https://www.huffpost.com/section/world-news" target="_self">World News</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Business" data-subsec="news" href="https://www.huffpost.com/impact/business" target="_self">Business</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Environment" data-subsec="news" href="https://www.huffpost.com/impact/green" target="_self">Environment</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Health" data-subsec="news" href="https://www.huffpost.com/section/health" target="_self">Health</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Social Justice" data-subsec="news" href="https://www.huffpost.com/impact/topic/social-justice" target="_self">Social Justice</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Politics" data-subsec="politics" href="https://www.huffpost.com/news/politics" target="_self">Politics</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Congress" data-subsec="politics" href="https://www.huffpost.com/news/topic/us-congress" target="_self">Congress</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Donald Trump" data-subsec="politics" href="https://www.huffpost.com/news/topic/donald-trump" target="_self">Donald Trump</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="2020 Election Tracker" data-subsec="politics" href="https://www.huffpost.com/elections" target="_self">2020 Election Tracker</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Extremism" data-subsec="politics" href="https://www.huffpost.com/news/topic/extremism" target="_self">Extremism</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Entertainment" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/" target="_self">Entertainment</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Culture &amp; Arts" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/arts" target="_self">Culture &amp; Arts</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Media" data-subsec="entertainment" href="https://www.huffpost.com/news/media" target="_self">Media</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Celebrity" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/celebrity" target="_self">Celebrity</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="TV &amp; Film" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/tv" target="_self">TV &amp; Film</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Life" data-subsec="life" href="https://www.huffpost.com/life/" target="_self">Life</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Style &amp; Beauty" data-subsec="life" href="https://www.huffpost.com/life/style" target="_self">Style &amp; Beauty</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Food &amp; Drink" data-subsec="life" href="https://www.huffpost.com/life/taste" target="_self">Food &amp; Drink</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Parenting" data-subsec="life" href="https://www.huffpost.com/life/parents" target="_self">Parenting</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Travel" data-subsec="life" href="https://www.huffpost.com/life/travel" target="_self">Travel</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Finds" data-subsec="life" href="https://www.huffpost.com/life/topic/finds" target="_self">Finds</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Wellness" data-subsec="life" href="https://www.huffpost.com/life/healthy-living" target="_self">Wellness</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Relationships" data-subsec="life" href="https://www.huffpost.com/life/relationships" target="_self">Relationships</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Money" data-subsec="life" href="https://www.huffpost.com/life/money" target="_self">Money</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Home &amp; Living" data-subsec="life" href="https://www.huffpost.com/life/huffpost-home" target="_self">Home &amp; Living</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Work/Life" data-subsec="life" href="https://www.huffpost.com/life/worklife" target="_self">Work/Life</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Communities" data-subsec="communities" href="https://www.huffpost.com/voices/" target="_self">Communities</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Queer Voices" data-subsec="communities" href="https://www.huffpost.com/voices/queer-voices" target="_self">Queer Voices</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Women" data-subsec="communities" href="https://www.huffpost.com/voices/women" target="_self">Women</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Black Voices" data-subsec="communities" href="https://www.huffpost.com/voices/black-voices" target="_self">Black Voices</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Latino Voices" data-subsec="communities" href="https://www.huffpost.com/voices/latino-voices" target="_self">Latino Voices</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Asian Voices" data-subsec="communities" href="https://www.huffpost.com/voices/asian-voices" target="_self">Asian Voices</a>
</div>
<div class="left-nav__menu__group">
<span class="left-nav__menu__item left-nav__menu__item--heading">Special Projects</span>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Work In Progress" data-subsec="special-projects" href="https://www.huffpost.com/impact/topic/impact-business" target="_self">Work In Progress</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Impact: This New World" data-subsec="special-projects" href="https://www.huffpost.com/impact/topic/this-new-world" target="_self">Impact: This New World</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Highline" data-subsec="special-projects" href="https://highline.huffingtonpost.com/" target="_blank">Highline</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Listen to America" data-subsec="special-projects" href="https://www.huffpost.com/feature/listen-to-america" target="_self">Listen to America</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Podcasts" data-subsec="special-projects" href="https://www.huffpost.com/entertainment/topic/podcasts" target="_self">Podcasts</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="HuffPost Personal" data-subsec="huffpost-personal" href="https://www.huffpost.com/section/huffpost-personal" target="_self">HuffPost Personal</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Video" data-subsec="video" href="https://www.huffpost.com/section/video" target="_self">Video</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Horoscopes" data-subsec="horoscopes" href="https://www.huffpost.com/horoscopes" target="_self">Horoscopes</a>
<span class="grid-placeholder"></span>
</div>
<div class="left-nav__menu__group">
<span class="left-nav__menu__item left-nav__menu__item--heading">From Our Partners</span>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Women&#39;s Work" data-subsec="womenswork" href="https://www.huffpost.com/feature/womenswork" target="_self">Women&#39;s Work</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="What&#39;s Working: Purpose + Profit" data-subsec="from-our-partners" href="https://www.huffpost.com/impact/topic/purpose-profit" target="_self">What&#39;s Working: Purpose + Profit</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Newsletters" data-subsec="newsletters" href="https://www.huffpost.com/newsletters" target="_self">Newsletters</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Coupons" data-subsec="coupons" href="https://coupons.huffpost.com" target="_blank">Coupons</a>
<span class="grid-placeholder"></span>
</div>
<div class="left-nav__menu__group">
<span class="left-nav__menu__item left-nav__menu__item--heading">International</span>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Australia" data-subsec="international" href="https://www.huffingtonpost.com.au/" target="_self">Australia</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Brazil" data-subsec="international" href="https://www.huffpostbrasil.com/" target="_self">Brazil</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Canada" data-subsec="international" href="https://www.huffingtonpost.ca/" target="_self">Canada</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="España" data-subsec="international" href="https://www.huffingtonpost.es" target="_self">España</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="France" data-subsec="international" href="https://www.huffingtonpost.fr" target="_self">France</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Ελλάδα (Greece)" data-subsec="international" href="https://www.huffingtonpost.gr" target="_self">Ελλάδα (Greece)</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="India" data-subsec="international" href="https://www.huffingtonpost.in" target="_self">India</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Italia" data-subsec="international" href="https://www.huffingtonpost.it" target="_self">Italia</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="日本 (Japan)" data-subsec="international" href="https://www.huffingtonpost.jp" target="_self">日本 (Japan)</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="한국 (Korea)" data-subsec="international" href="https://www.huffingtonpost.kr" target="_self">한국 (Korea)</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Quebec" data-subsec="international" href="https://quebec.huffingtonpost.ca" target="_self">Quebec</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="U.K." data-subsec="international" href="https://www.huffingtonpost.co.uk/" target="_self">U.K.</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="U.S." data-subsec="international" href="https://www.huffpost.com/" target="_self">U.S.</a>
</div>
</div>
<div class="left-nav__social">
<div class="social-buttons__title">Follow us</div>
<div class="social-buttons__icons">
<a class="social-buttons__icons__item social-buttons__icons__item--facebook yr-follow-item" data-button-name="facebook" href="https://facebook.com/HuffPost" target="_blank"></a>
<a class="social-buttons__icons__item social-buttons__icons__item--twitter yr-follow-item" data-button-name="twitter" href="https://twitter.com/HuffPost" target="_blank"></a>
<a class="social-buttons__icons__item social-buttons__icons__item--instagram yr-follow-item" data-button-name="instagram" href="https://instagram.com/HuffPost" target="_blank"></a>
</div>
</div>
<div class="left-nav__footer-links">
<a class="left-nav__footer__link" href="https://www.verizonmedia.com/policies/us/en/verizonmedia/terms/otos/index.html">Terms</a>
<span class="left-nav__footer-links__divider">|</span>
<a class="left-nav__footer__link" href="https://www.verizonmedia.com/policies/us/en/verizonmedia/privacy/index.html">Privacy Policy</a>
</div>
<div class="left-nav__copyright">
Part of HuffPost Entertainment. ©2020 Verizon Media. All rights reserved. Huffington Post.
</div>
</div>
</div>


<div class="breaking-news-banner js-breaking-news-banner yr-breaking-news">
<div class="breaking-news-banner__fixed">BREAKING NEWS</div>
<a class="breaking-news-banner__text js-breaking-news-banner-text yr-breaking-news-link"></a>
<div class="breaking-news-banner__close js-breaking-news-banner-close yr-close yr-track"></div>
</div>

<div class="desktop-alerts-signup js-desktop-alerts-signup yr-desktop-alert-signup hidden">
<div class="desktop-alert-signup__inner">
<div class="desktop-alerts-center">
<div class="desktop-alerts-bell js-desktop-alerts-bell"></div>
<div class="desktop-alerts-banner-text js-desktop-alerts-banner-text">Tap here to turn on desktop notifications to get the news sent straight to you.</div>
</div>
<div class="desktop-alerts-close js-desktop-alerts-banner-close yr-close yr-track"></div>
</div>
</div>
<header class="header js-header " data-yaft-module="huffpost-top-nav">
<div class="header__content yr-masthead">
<div class="header__content-left js-header-content-left">
<div class="header__hamburger js-hamburger-button-container">
<button class="header__hamburger-link yr-hamburger-button yr-track js-hamburger-link"></button>
</div>
<div class="header__search js-search-container">
<button aria-label="Search HuffPost" class="header__search-glass-button js-search-button">
<span>Open Search</span>
</button>
<form id="header-search-form" action="https://search.huffpost.com/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" /><input class="header__search-glass" type="submit" value="search">
<input type="text" name="p" id="header-search-input" placeholder="Search HuffPost" class="header__search-input" autocomplete="off" aria-label="Enter Search Text" />
<div class="search-results" id="header-search-results"></div>
</form></div>
</div>
<div class="header__logo">
<a class="logo yr-logo-image" href="https://www.huffpost.com">
<img alt="HuffPost" class="header__logo__img" src="https://s.m.huffpost.com/assets/HuffPostHero-d783f680fb974e80346bdfa145131d058e596e1d32f791981875aa481702c770.svg">
</a>
</div>
<div class="header__content-right">
<hp-replace class="header__profile" id="global-header-profile-block">
<a class="header__profile__circle yr-modal-profile-circle-logged-out" href="https://oidc.huffpost.com/login?dest=https%3A%2F%2Fwww.huffpost.com%2Fentry%2Fgregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e"></a>
<a class="header__profile__log-in yr-modal-login" href="https://oidc.huffpost.com/login?dest=https%3A%2F%2Fwww.huffpost.com%2Fentry%2Fgregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e">Log In</a>
<a class="header__profile__subscription-button" href="https://www.huffpost.com/subscribe?ncid=huffpost_globaldesk_ct6htebthyu">Join HuffPost Plus</a>
<script type="text/template">
<a class="header__profile__subscription-button {{__HP-SUBSCRIPTION-BUTTON-CLASSES__}}" href="https://www.huffpost.com/subscribe?ncid=huffpost_globaldesk_ct6htebthyu">Join HuffPost Plus</a>
<a aria-label="Profile" class="header__profile__image-link yr-modal-profile-circle-logged-in" href="https://www.huffpost.com/member">
<img class="header__profile__image" src="{{__HP-USER-PROFILE-IMAGE-URL__}}">
</a>
</script>
</hp-replace>
</div>
</div>
</header>



<nav class="subnav js-subnav yr-subnav subnav--entry" id="nav">
<div class="subnav__content">
<div class="subnav__left">
<div class="subnav__hamburger js-hamburger-button-container">
<button class="subnav__hamburger-link yr-hamburger-button yr-track js-hamburger-link"></button>
</div>
<a class="subnav__logo__link" href="https://www.huffpost.com">
<img alt="HuffPost" class="subnav__logo--big js-non-entry-sticky" src="https://s.m.huffpost.com/assets/HuffPostHero-d783f680fb974e80346bdfa145131d058e596e1d32f791981875aa481702c770.svg">
<img alt="HuffPost" class="subnav__logo--small" src="https://s.m.huffpost.com/assets/H-icon-72fd5782b36a1a42ab82a4af65cbc6dd6ddc4d4a71190a91c5cfaab7c66fd836.svg">
</a>
</div>
<div class="nav-sticky__entry js-nav-entry hidden">
<div class="nav-sticky__item nav-sticky__title">'Twilight' Actor Gregory Tyree Boyce Dead At 30</div>
<div class="nav-sticky__item nav-sticky__sharebar">
<div class="js-sharebar share-bar share-bar--nav-sticky" data-mobilepath="/us/entry/5ec31ec4c5b6b973546ff05e" data-sharingimage="https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&amp;ops=1778_1000" data-sharingtitle="&#39;Twilight&#39; Actor Gregory Tyree Boyce Dead At 30" data-sharingtweetname="HuffPostEnt" data-sharingtweettext="%22Twilight%22+star+Gregory+Tyree+Boyce+has+died+at+age+30." data-sharingurl="https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" data-yaft-module="">
<ul class="share-bar__list yr-share">
<li class="bookmark share-bar__item" data-share-name="bookmark" data-type="bookmark">
<a aria-label="Share on bookmark" class="bookmark js-bookmark-button yr-no-track share-bar__item-link yr-share-item" data-share-name="bookmark" href="javascript:void(0);" role="button" target="_self"></a>
</li>

<li class="facebook share-bar__item" data-share-name="facebook" data-type="facebook">
<a aria-label="Share on facebook" class="facebook share-bar__item-link yr-share-item" data-share-name="facebook" href="https://facebook.com/share.php?u=https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" role="button" target="_blank"></a>
</li>

<li class="share-bar__item twitter" data-share-name="twitter" data-type="twitter">
<a aria-label="Share on twitter" class="share-bar__item-link twitter yr-share-item" data-share-name="twitter" href="https://twitter.com/share?text=%22Twilight%22+star+Gregory+Tyree+Boyce+has+died+at+age+30.&amp;url=https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e&amp;via=HuffPostEnt&amp;hashtags=" role="button" target="_blank"></a>
</li>

<li class="email share-bar__item" data-share-name="email" data-type="email">
<a aria-label="Email this article" class="email share-bar__item-link yr-share-item" data-share-name="email" href="mailto:?subject=&#39;Twilight&#39;%20Actor%20Gregory%20Tyree%20Boyce%20Dead%20At%2030&amp;body=Article: https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" role="button"></a>
</li>

<div class="share-bar__item js-sharebar-comments yr-share-item yr-track" data-share-name="comments_open" data-type="comments">
<div class="share-bar__comments__icon"></div>
</div>
</ul>
</div>

</div>
</div>
<div class="subnav__items js-subnav-items js-non-entry-sticky">
<a class="subnav__item yr-subnav-link" href="/news/">NEWS</a>
<a class="subnav__item yr-subnav-link" href="https://www.huffpost.com/feature/coronavirus">CORONAVIRUS</a>
<a class="subnav__item yr-subnav-link" href="/news/politics">POLITICS</a>
<a class="subnav__item yr-subnav-link" href="/elections">2020 ELECTIONS</a>
<a class="subnav__item subnav__item--current yr-subnav-link" href="/entertainment/">ENTERTAINMENT</a>
<a class="subnav__item yr-subnav-link" href="/life/">LIFE</a>
<a class="subnav__item yr-subnav-link" href="/section/huffpost-personal">PERSONAL</a>
<a class="subnav__item yr-subnav-link" href="/section/video">VIDEO</a>
<a class="subnav__item yr-subnav-link" href="/life/topic/finds">SHOPPING</a>
</div>

<div class="editions-menu js-editions-menu yr-editions-menu">
<div class="editions-menu__list">
<div class="editions-menu__list__item current">U.S.</div>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Canada" href="https://www.huffingtonpost.ca?country=CA">Canada</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="U.K." href="https://www.huffingtonpost.co.uk?country=UK">U.K.</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Australia" href="https://www.huffingtonpost.com.au?country=AU">Australia</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Brazil" href="https://www.huffpostbrasil.com?country=BR">Brazil</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="España" href="https://www.huffingtonpost.es?country=ES">España</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="France" href="https://www.huffingtonpost.fr?country=FR">France</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Ελλάδα (Greece)" href="https://www.huffingtonpost.gr?country=GR">Ελλάδα (Greece)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="India" href="https://www.huffingtonpost.in?country=IN">India</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Italia" href="https://www.huffingtonpost.it?country=IT">Italia</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="日本 (Japan)" href="https://www.huffingtonpost.jp?country=JP">日本 (Japan)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="한국 (Korea)" href="https://www.huffingtonpost.kr?country=KR">한국 (Korea)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Quebec" href="https://quebec.huffingtonpost.ca?country=QC">Quebec</a>
</div>
</div>

<button aria-expanded="false" class="subnav__editions-menu__toggle closed js-edition-toggle yr-editions-button yr-track js-non-entry-sticky">U.S. Edition</button>
</div>
</nav>

<div class="header__placeholder js-header-placeholder"></div>
<div class="leaderboard-flex-placeholder"></div>

<div class="advertisement leaderboard_flex" data-placement="leaderboard_flex" data-yaft-module="huffpost-leaderboard_flex">
<style type="text/css"> #topnav_margin_btm { margin: 0 !important; } </style>
<div id="ad_leaderboard_flex" class="ad_wrapper_">
<div id="adtech_leaderboard_flex" class="adtech-adspot ad-leaderboard_flex"></div>

<script>
(function() {
  var disableAdRotation = "0" === "1";
  var adsDiv = document.querySelector('#adtech_leaderboard_flex');
  adsDiv.removeAttribute('id');

  var defaultDelivery = "f";
  

  
  
  // enableQueue: "0"
 
    
      
        waitForGlobal(function() {
          return window.htmlAdWH && window.adSetSyncCalled;
        }, function() {
          // override adsPl in template
          if ('function' === typeof window.adSetPlId) {
            if ('undefined' === typeof window.origAdsPlId) { window.origAdsPlId = window.adsPl; }
            if ('undefined' !== typeof window.origAdsPlId) { window.adSetPlId(window.origAdsPlId); }
            
          }

          // override ads NetId in template
          if ('function' === typeof window.adSetNetId) {
            if ('undefined' === typeof window.origNetId) { window.origNetId = window.adsNt; }
            if ('undefined' !== typeof window.origNetId) { window.adSetNetId(window.origNetId); }
            
          }

          adsDiv.reloadCount = 0;
          var recoveryId = '';
          var needsRecovery = recoveryId && recoveryId.length && kraken__adBlock && kraken__adBlock.active;
          var adId = needsRecovery ? recoveryId : '93318066';
          // try { adId = io_c3sd.ads["leaderboard_flex"] || adId; } catch(e) {}

          
          

          // Override adtech_call_type
          var delivery_type = "default" || "";
          var adtech_call_type = "";
          switch (delivery_type) {
            case "by_request": adtech_call_type = "ajax"; break;
            case "text": adtech_call_type = "text"; break;
            case "iframe": adtech_call_type = "iframe"; break;
            case "iframe_proxy": adtech_call_type = "f"; break;
            case "collapsed": adtech_call_type = "fc"; break;
            default: adtech_call_type = defaultDelivery; break;
          }

          
          
          

          

          var args = ['lb', 'lb'
          ];

          
          

          
          
          

          

          if(needsRecovery) {
            waitForGlobal('readyToRecover', function() {
              adsDiv = document.querySelector('.leaderboard_flex');
              //htmlAdWH(adId, args[0], args[1], "fileless", adsDiv);
            });
          } else {
            console.log('calling MN ' + adId.toString());
            _uacModuleDebug("Element > [leaderboard_flex : "+ adId +": "+ args[0] +","+ args[1] +"]");
            htmlAdWH(adId, args[0], args[1], adtech_call_type, adsDiv);
            if (!disableAdRotation) {
              adsRotateMult(adsDiv);
            }
          }

          if (typeof debugadcode == 'function') { debugadcode('AdTech', {placement: 'leaderboard_flex', mnid: adId}, adsDiv); }

          waitForGlobal('jQuery', function() {
            jQuery(document).on('reloadAd', function(ev, elem) {
              if (elem && !elem.contains(adsDiv)) { return; }
              var refreshRate = 1;
              adsDiv.reloadCount++;
              if (adsDiv.reloadCount % refreshRate === 0 && typeof adsReloadAd === 'function') { adsReloadAd(adsDiv); }
            });
          });

          if ( !window.__adtechForceInView ) {
            console.log('adSetInView(0)');
            _uacModuleDebug("adSetInView('0') Changed back to 0 probably for next Ad call > [leaderboard_flex : " + adId + "]");
            adSetInView('0');
          }

          
        }); // wFG:htmlAdWH
      
    
   //modulous queue closing
}());
</script></div>
<script type="text/javascript">if (typeof HPAds !== 'undefined') { 
HPAds.ad_onload('div[id^="ad_leaderboard_flex"] iframe','HPAds.ad_uac_onload_handler(\' iframe[class^="uac_"]\',this,\'bottom_ad_border_div\',10)');
}</script>
</div>

<div id="main" role="main">





<article class="entry js-entry component loaded entry--standard" data-mobilepath="/us/entry/5ec31ec4c5b6b973546ff05e" data-sharingimage="https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&amp;ops=1778_1000" data-sharingtitle="&#39;Twilight&#39; Actor Gregory Tyree Boyce Dead At 30" data-sharingtweetname="HuffPostEnt" data-sharingtweettext="%22Twilight%22+star+Gregory+Tyree+Boyce+has+died+at+age+30." data-sharingurl="https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" data-socialmessaging="{}" data-yaft-module="" id="us_5ec31ec4c5b6b973546ff05e" path="/us/entry/us_5ec31ec4c5b6b973546ff05e" type="article">



<header class="entry__header yr-entry-header" data-yaft-module="huffpost-entry-header">



<span class="entry-eyebrow">
<span class="yr-department-tag">
<a class="entry-eyebrow__link yr-department-link" data-linkname="entertainment" href="https://www.huffpost.com/entertainment/entertainment">ENTERTAINMENT
</a></span>
</span>

<div class="timestamp">
<span aria-label="Published on May 18, 2020 08:34 PM ET" class="timestamp__date--published">
<span aria-hidden="true">05/18/2020 08:34 pm ET</span>
</span>
</div>






<div class="headline js-headline">
<h1 class="headline__title">'Twilight' Actor Gregory Tyree Boyce Dead At 30</h1>
<div class="headline__subtitle">Boyce was best known for his role as Tyler Crowley in "Twilight."</div>
</div>




<div class="byline yr-byline">
<div class="byline__authors">
<div class="author-card author-card--byline yr-author-card">
<div class="author-card__headshot">
<a class="author-card__link yr-author-image" aria-hidden="true" href="https://www.huffpost.com/author/josie-harvey"><img src="https://img.huffingtonpost.com/asset/5d884ea42100000606e9f6e6.png?ops=100_100" height="38px" width="38px" alt="headshot"></img>
</a></div>
<div class="author-card__details">
<div class="author-card__name"><span aria-hidden="true">By </span><a class="author-card__link yr-author-name" aria-label="By Josephine Harvey" href="https://www.huffpost.com/author/josie-harvey"><span aria-hidden="true">Josephine Harvey</span></a></div></div>
</div>

</div>
</div>

</header>

<div class="entry__content js-entry-content">
<div class="entry__body js-entry-body">


<div class="top-media js-top-media yr-top-media" data-yaft-module="huffpost-top-media">
<div class="top-media--image">

<figure class="content-list-component image yr-content-list-image">
<img class="image__src" src="https://img.huffingtonpost.com/asset/5ec321f5300000d31b156399.jpeg?ops=crop_9_51_2016_1242,scalefit_720_noupscale" alt="Actor Gregory Tyree Boyce, known for his role in the &quot;Twilight&quot; movies, has been found dead at age 30."></img>
<div class="image__meta-wrapper js-image-meta-wrapper">
<span aria-label="Image credit: Vivien Killilea via Getty Images" class="image__credit">
<span aria-hidden="true">
Vivien Killilea via Getty Images
</span>
</span>
<figcaption class="image__caption">
Actor Gregory Tyree Boyce, known for his role in the "Twilight" movies, has been found dead at age 30.
</figcaption>
</div>
</figure>

</div>
<!--  -->
<script></script>
<iframe style="display: none;"></iframe>

</div>

<div class="js-sharebar share-bar share-bar--sticky yr-left-rail" data-mobilepath="/us/entry/5ec31ec4c5b6b973546ff05e" data-sharingimage="https://img.huffingtonpost.com/asset/5ec31f53300000a71b156398.jpeg?cache=lg44ogrspk&amp;ops=1778_1000" data-sharingtitle="&#39;Twilight&#39; Actor Gregory Tyree Boyce Dead At 30" data-sharingtweetname="HuffPostEnt" data-sharingtweettext="%22Twilight%22+star+Gregory+Tyree+Boyce+has+died+at+age+30." data-sharingurl="https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" data-yaft-module="huffpost-sticky-share">
<ul class="share-bar__list yr-share">
<li class="bookmark share-bar__item" data-share-name="bookmark" data-type="bookmark">
<a aria-label="Share on bookmark" class="bookmark js-bookmark-button yr-no-track share-bar__item-link yr-share-item" data-share-name="bookmark" href="javascript:void(0);" role="button" target="_self"></a>
</li>

<li class="facebook share-bar__item" data-share-name="facebook" data-type="facebook">
<a aria-label="Share on facebook" class="facebook share-bar__item-link yr-share-item" data-share-name="facebook" href="https://facebook.com/share.php?u=https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" role="button" target="_blank"></a>
</li>

<li class="share-bar__item twitter" data-share-name="twitter" data-type="twitter">
<a aria-label="Share on twitter" class="share-bar__item-link twitter yr-share-item" data-share-name="twitter" href="https://twitter.com/share?text=%22Twilight%22+star+Gregory+Tyree+Boyce+has+died+at+age+30.&amp;url=https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e&amp;via=HuffPostEnt&amp;hashtags=" role="button" target="_blank"></a>
</li>

<li class="pinterest share-bar__item" data-share-name="pinterest" data-type="pinterest">
<a aria-label="Share on pinterest" class="pinterest share-bar__item-link yr-share-item" data-share-name="pinterest" data-pin-custom="true" href="#" role="button" target="_blank"></a>
</li>

<li class="email share-bar__item" data-share-name="email" data-type="email">
<a aria-label="Email this article" class="email share-bar__item-link yr-share-item" data-share-name="email" href="mailto:?subject=&#39;Twilight&#39;%20Actor%20Gregory%20Tyree%20Boyce%20Dead%20At%2030&amp;body=Article: https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" role="button"></a>
</li>

<div class="share-bar__item js-sharebar-comments yr-share-item yr-track" data-share-name="comments_open" data-type="comments">
<div class="share-bar__comments__icon"></div>
</div>
</ul>
</div>


<div class="share-bar-highlight js-highlight hidden yr-highlight">
<div class="yr-share">
<a class="share-bar-highlight__twitter js-highlight-share-button yr-share-item" data-share-name="twitter" data-type="twitter"></a>
<a class="share-bar-highlight__facebook js-highlight-share-button yr-share-item" data-share-name="facebook" data-type="facebook"></a>
</div>
</div>

<div class="entry__text js-entry-text yr-entry-text" data-yaft-module="huffpost-entry-text">
<div class="content-list-component yr-content-list-text text"><p>“Twilight” actor Gregory Tyree Boyce has died at age 30.</p></div>
<div class="content-list-component yr-content-list-text text"><p>The actor and his girlfriend, Natalie Adepoju, 27, were found dead in a Las Vegas condo on May 13, the Las Vegas Medical Examiner’s Office confirmed to <a href="https://www.etonline.com/gregory-tyree-boyce-twilight-actor-dead-at-30-146799" target="_blank" rel="noopener noreferrer">ET</a> and <a href="https://www.eonline.com/au/news/1153320/twilight-star-gregory-tyree-boyce-dead-at-30" target="_blank" rel="noopener noreferrer">E! News</a>, which first reported the death.</p></div>
<div class="content-list-component yr-content-list-text text"><p>Boyce is best known for his role as Tyler Crowley in the “Twilight” franchise. Over the weekend, his mother, Lisa Wayne, shared the news in a heartbreaking post to social media.</p></div>
<div class="content-list-component yr-content-list-text text"><p>She said her son was an incredible chef and was chasing his passion and starting a chicken wing business, West Wings. </p></div>
<div class="content-list-component yr-content-list-text text"><p>“He created the flavors to his perfection and named them after west coast rappers,” she wrote. “Snoop Dog, Kendrick Lamar, Roddy Ricch, The Game, etc. He had flavors like, Tequila Lime Agave... those were my favorite.”</p></div>
<div class="content-list-component yr-content-list-text text"><p>She added: “I’m sick without you. I’m torn, I’m lost. I’m in pain. I’d text you or call you when I was broken or worried about something, and you’d tell me, Ma, I got you, we’ll get thru this together.”</p></div>
<div class="content-list-component yr-content-list-text text"><p>Wayne said she last saw her son on Mother’s Day. “I went to your house to eat leftovers from Mother’s day, we watched a Dave Chappelle show and you walked me to my car, hugged me, kissed me on my cheek and told me that you love me and to call you when I got home,” she wrote. </p></div>
<div class="content-list-component yr-content-list-text text"><p>Boyce’s last post on Instagram was of him and Adepoju on Mother’s Day.</p></div>
<div class="content-list-component embed-asset yr-content-list-embed"><blockquote class="instagram-media" data-instgrm-permalink="https://www.instagram.com/p/CABcaCuAzjc/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-captioned data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CABcaCuAzjc/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div></a><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/CABcaCuAzjc/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by Ggr8T (@mr_alwaysgrindn)</a> on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-05-10T21:32:56+00:00">May 10, 2020 at 2:32pm PDT</time></p></div></blockquote>
<script async src="https://www.instagram.com/embed.js"></script></div>
<div class="content-list-component yr-content-list-text text"><p>Adepoju’s family <a href="https://www.gofundme.com/f/final-goodbye-for-natalie-adepoju" target="_blank" rel="noopener noreferrer">wrote in a GoFundMe</a> post seeking help with memorial costs that she was a “loving daughter, niece, sister, cousin and friend.”</p></div>
<div class="content-list-component yr-content-list-text text"><p>“Natalie had so much life to live we are saddened that her life was cut short,” it said. “Natalie leaves behind her one and only baby boy Egypt, her father, 2 brothers and 1 sister, and a host of family and friends who love her dearly.”</p></div>
<div class="content-list-component yr-content-list-text text"><p>Boyce is survived by his 10-year-old daughter, Alaya.</p></div>
<div class="content-list-component yr-content-list-text text"><p>The cause of death has not yet been disclosed.</p></div>


<script class="entry-paragraph-1-ad-script-template" type="text/template">

</script>
<script class="sharebox-ad-script-template" type="text/template">

</script>
<script class="in-line-ad-unit-script-template" type="text/template">

</script>
<div id="inline-newsletter_placeholder"></div>

<section class="app-download-interstitial hidden js-app-download-interstitial yr-app-download" data-block-class="app-download-interstitial">
<div class="app-download-interstitial__container">
<div class="app-download-interstitial__left">
<div class="app-download-interstitial__logo"></div>
<div class="app-download-interstitial__title js-app-download-interstitial-title"></div>
<a class="app-download-interstitial__download-app js-app-download-interstitial-app-store" href="https://app.appsflyer.com/{{id}}?pid=Acquisition&amp;c=US_Internal_YMktg_HuffPostMobileWebBP_House_Users&amp;af_sub1=Internal&amp;af_sub2=US_YMktg_US_YMktg&amp;af_sub3=Mid_Evergreen_v2">Download</a>
</div>
<div class="app-download-interstitial__right">
<div class="app-download-interstitial__device"></div>
</div>
</div>
</section>

<section class="hidden entry-inline-subscription-module js-entry-inline-subscription-module">
<div class="inline-subscription-module">
<div class="inline-subscription-module__text">
<div class="inline-subscription-module__svg">
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  --><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" viewBox="0 0 720 90" style="enable-background:new 0 0 720 90;" xml:space="preserve" height="17px" width="144px">
<style type="text/css">
	.st0{display:none;}
	.st1{display:inline;}
	.st2{fill:#FFFFFF;}
	.st3{fill:#0DBE98;}
</style>
<g id="Layer_2" class="st0">
	<rect class="st1" width="720" height="90"></rect>
</g>
<g id="Layer_1">
	<g>
		<g>
			<path class="st2" d="M93.1,85.4h26.3l14.1-80.7h-26.3L102,33.6H79.2l5.2-28.9H58.1L44,85.4h26.3l5.3-30.2h22.8L93.1,85.4z"></path>
		</g>
		<g>
			<path class="st2" d="M148.4,4.6l-8,44.9c-0.7,3.5-1,6.9-1,10.1c0,23.8,20.8,27.4,33.3,27.4c26.2,0,37.5-8.7,41.6-32.2l8.8-50.3     h-26.3l-7.5,42.2c-2.4,13.2-4.1,20.1-13.9,20.1c-6.4,0-9.5-3.4-9.5-10.4c0-2.7,0.4-6,1.2-10.1l7.6-41.8H148.4z"></path>
		</g>
		<g>
			<path class="st2" d="M362.1,85.4h26.3l3.7-20.8h12.4c22.9,0,35.6-12.4,35.6-35c0-15.9-11-25-30.3-25h-33.6L362.1,85.4z      M403.1,44.7h-7.6l3.5-19h7.1c5.8,0,8.9,2.9,8.9,8.2C415,40.6,410.5,44.7,403.1,44.7z"></path>
		</g>
		<g>
			<path class="st2" d="M491.2,2.9c-28.6,0-45.7,18.5-45.7,49.6c0,21.6,13.6,34.6,36.4,34.6c28.6,0,45.7-18.5,45.7-49.6     C527.7,15.8,514.1,2.9,491.2,2.9z M483.5,66.2c-6.8,0-10.8-4.9-10.8-13.1c0-3.1,0.3-5.8,0.9-8.9c2-10.6,5.4-20.3,16.1-20.3     c6.8,0,10.8,4.9,10.8,13.1c0,3.1-0.3,5.8-0.9,8.9C497.6,56.4,494.2,66.2,483.5,66.2z"></path>
		</g>
		<g>
			<path class="st2" d="M619.1,85.4h26.3l10.4-59.1h19.8l3.8-21.6h-67.3l-3.8,21.6h21L619.1,85.4z"></path>
		</g>
		<path class="st2" d="M575.5,34.5c-8.3-2.6-11.7-3.7-11.7-7.6c0-2.6,1.7-5.7,6.7-5.7c3.7,0,6.8,2.1,8,5.2l23.2-6.3    c-2.7-11.4-12.5-17.2-29.4-17.2c-31.8,0-34.3,21.3-34.3,27.8c0,13.2,7,21.3,22.2,25.5c4,1.1,8.6,2.3,8.6,6.7    c0,3.5-2.6,5.7-7.1,5.7c-4.1,0-8.5-2.4-10-6.6l-22.9,6.2c2.5,12,13.8,18.8,31.5,18.8c13.5,0,36.1-3.6,36.1-28    C596.5,46.8,589.6,38.8,575.5,34.5z"></path>
		<g>
			<path class="st3" d="M29.3,85.4L43.5,4.7H0v80.7L29.3,85.4z"></path>
		</g>
		<g>
			<path class="st3" d="M690.7,4.7l-14.1,80.7l43.5,0V4.7L690.7,4.7z"></path>
		</g>
		<polygon class="st2" points="238.1,4.6 224,85.4 250.3,85.4 254.5,61.6 276.6,61.6 280.2,41.3 258.1,41.3 260.6,26.3 291.5,26.3     295.3,4.6   "></polygon>
		<polygon class="st2" points="307.1,4.6 293,85.4 319.3,85.4 323.4,61.6 345.6,61.6 349.2,41.3 327.1,41.3 329.6,26.3 360.5,26.3     364.3,4.6   "></polygon>
	</g>
</g>
</svg>

</div>
<div class="inline-subscription-module__title" data-ab="huffpostPlusMidEntryCta3" data-ab-b-title="Last chance to become a HuffPost founding member!" data-ab-c-title="Last chance to become a HuffPost founding member!">Calling all HuffPost superfans!</div>
<div class="inline-subscription-module__description" data-ab="huffpostPlusMidEntryCta3" data-ab-b-desc="Sign up and help shape HuffPost&#39;s next chapter" data-ab-c-desc="Sign up for membership and help shape HuffPost&#39;s next chapter">Sign up for membership to become a founding member and help shape HuffPost's next chapter</div>
</div>
<div class="inline-subscription-module__button__container">
<a class="inline-subscription-module__button" data-ab="huffpostPlusMidEntryCta3" data-ab-b-btn="Become a founding member" data-ab-b-href="https://login.huffpost.com/account/create?specId=usernameRegWithNoGender&amp;ncid=huffpost_epv2_rd2j4gtkbas" data-ab-c-btn="Yes, I want to support HuffPost" data-ab-c-href="https://login.huffpost.com/account/create?specId=usernameRegWithNoGender&amp;ncid=huffpost_epv3_bcpcogkwpoe" href="https://login.huffpost.com/account/create?specId=usernameRegWithNoGender&amp;ncid=huffpost_epv1_vc5rcp5vulq">Join HuffPost</a>
</div>
</div>

</section>

<script class="bachelor-podcast_script-template" type="text/template">
<a class="bachelor-podcast js-bachelor-podcast yr-bachelor-podcast" href="#" target="_blank">
<div class="bachelor-podcast__roses"></div>
<div class="bachelor-podcast__circle">
<div class="bachelor-podcast__title1"></div>
<div class="bachelor-podcast__title2"></div>
<div class="bachelor-podcast__logo"></div>
<div class="bachelor-podcast__title3"></div>
</div>
</a>

</script>
<div class="teads-entry-placement js-teads-entry-placement">
<div class="teads-entry__content" id="teads-entry-desktop">


</div>
</div>

<script class="mobileweb_transporter_mid_script-template" type="text/template">

</script>
<script class="mobileweb_transporter_mid_2_script-template" type="text/template">

</script>
<script class="entry-paragraph-3-ad-script-template" type="text/template">

</script>
</div>
<!--  -->
<script></script>
<iframe style="display: none;"></iframe>


<script class="article-bottom-ad-script-template" type="text/template">

</script>



<div id="insert-autoembed-here"></div>
<script id="autoembed-template" type="text/template">
<section class="extra-content yr-extra-content">
  <div class="extra-content-eyebrow">
<div class="extra-content-eyebrow__donut">
<img alt="HuffPost" class="extra-content-eyebrow__donut__src" src="https://s.m.huffpost.com/assets/donut-a63d2a21ca5f04f551be212a9496d4deba5d40f4bcb801f34ba14f27bb3bb32a.svg">
</div>
<h4 class="extra-content-eyebrow__text">BEFORE YOU GO</h4>
</div>

  <div class="extra-content__media">
    <div class="content-list-component embed-asset yr-content-list-embed ">
      <div id="max-player-injector"></div>
    </div>
  </div>
</section>


</script>
<script>
  window.maxConfig = {
    global: {
      onLoadTimeout: 10, //optional
      player: {"pid":"5ca245d0791cad63737ada0e","bcid":"56000e19e4b0e4e194b84b31","m.playertype":"html","m.onLoad":"getVidiblePlayer","m.loadingplaceholder":"1","m.sec":1,"m.playback":"autoplay_when_in_view","m.autoplayinview":"50","m.fwsitesection":"us.entertainment","m.paid_p":"the_huffington_post_584=hpo:5ec31ec4c5b6b973546ff05e","m.pt":"content","m.pct":"story","m.channel":"us.hpmgent","m.ss":"us.hpmgent"},
      // template that include the "Before you go” wrapper
      template: document.getElementById('autoembed-template').innerHTML,
    },
    strategies: [{
      //huffpost - before you go with template, when no player other exists on page (autoplay)
      type: 'INSERT',
      cssSelector: '#insert-autoembed-here',
      toggle: false, // keep player in page after video ends
      insertAfter: false,
      injectIfPlayerAlreadyExists: true
    }],
  }
</script>
<script src="https://cdn.vidible.tv/prod/max-suite/latest/max.js"></script>



<div class="entry_footer yr-entry-footer">


<div class="byline-footer">
<div class="byline-footer__authors yr-authors">
<div class="author-card author-card--byline-footer yr-author-card">
<div class="author-card__headshot">
<a class="author-card__link yr-author-image" aria-hidden="true" href="https://www.huffpost.com/author/josie-harvey"><img src="https://img.huffingtonpost.com/asset/5d884ea42100000606e9f6e6.png?ops=100_100" height="38px" width="38px" alt="headshot"></img>
</a></div>
<div class="author-card__details">
<div class="author-card__name"><a class="author-card__link yr-author-name" aria-label="More from Josephine Harvey" href="https://www.huffpost.com/author/josie-harvey"><span aria-hidden="true">Josephine Harvey</span></a></div><span class="author-card__social-container">
<a aria-label="Follow Josephine Harvey on twitter" class="author-card__social author-card__social--twitter yr-author-twitter" href="https://www.twitter.com/@JosieHarvey_" role="button" target="_blank"></a>
</span>
<div class="author-card__microbio">Trends Reporter, HuffPost</div>
</div>
</div>

</div>
<div class="byline-footer__right">
<div class="entry-corrections js-entry-corrections">
<a aria-label="Click to suggest a correction" class="suggest-correction yr-correction-link" href="javascript:void(0)" id="suggest-correction-link" role="button">Suggest a correction</a>
</div>

</div>
</div>

<div class="tag-cloud js-tag-cloud yr-tag-cloud">
<h4 aria-label="Read more in the following topics" class="tag-cloud__header">MORE:</h4>
<a class="tag yr-tag" data-slug="obit" href="https://www.huffpost.com/topic/obituary">
Obituaries
</a>
<a class="tag yr-tag" data-slug="twilight-film" href="https://www.huffpost.com/topic/twilight-film">
Twilight  Film
</a>
<a class="tag yr-tag" data-slug="gregory-tyree-boyce" href="https://www.huffpost.com/topic/gregory-tyree-boyce">
Gregory Tyree Boyce
</a>
</div>


<div id="suggested-story"></div>

</div>
<div class="below-entry js-below-entry">
<div class="below-entry__content" id="below-entry-desktop">


<div class="advertisement below_entry_recirc" data-placement="below_entry_recirc" data-yaft-module="huffpost-below_entry_recirc">
<div id="taboola-below-article-thumbnails" class="taboola hp-entry-you_may_like"></div>
<div id="hp-more-gravity"></div>
<script>
    (function(){
        var c = document.getElementById('taboola-below-article-thumbnails');
        c.id += '-' + Math.round(Math.random()*1e16);
        
        var taboolaParams = {
            loader: "https://cdn.taboola.com/libtrc/aol-huffingtonpost/loader.js",
            mode: "thumbnails-o",
            container: c.id,
            placement: "Below Article Thumbnails",
            target_type: "mix"
        };
        
        if (typeof window.modulousQueue === "function") {
        	window.modulousQueue.add(function(){ doTaboola(taboolaParams); });
        } else {
        	doTaboola(taboolaParams);
        }
    }());
</script>
</div>


</div>
</div>

</div>
<script>
  window.HP.modules.smarten.selector('.js-entry');
</script>

<div class="js-right-rail right-rail yr-right-rail">
<div id="vidible-anchor"></div>
<div class="swappinator js-swappinator"></div>

<div class="advertisement right_rail_flex" data-placement="right_rail_flex" data-yaft-module="huffpost-right_rail_flex">
<script type="text/javascript">
  if ( "function" === typeof(adSetSyncDelay) ) {
    adSetSyncDelay('125');
  }
</script>
<div id="ad_right_rail_flex" class="ad_wrapper_top">
<div id="adtech_right_rail_flex" class="adtech-adspot ad-right_rail_flex"></div>

<script>
(function() {
  var disableAdRotation = "0" === "1";
  var adsDiv = document.querySelector('#adtech_right_rail_flex');
  adsDiv.removeAttribute('id');

  var defaultDelivery = "f";
  

  
  
  // enableQueue: "0"
 
    
      
        waitForGlobal(function() {
          return window.htmlAdWH && window.adSetSyncCalled;
        }, function() {
          // override adsPl in template
          if ('function' === typeof window.adSetPlId) {
            if ('undefined' === typeof window.origAdsPlId) { window.origAdsPlId = window.adsPl; }
            if ('undefined' !== typeof window.origAdsPlId) { window.adSetPlId(window.origAdsPlId); }
            
          }

          // override ads NetId in template
          if ('function' === typeof window.adSetNetId) {
            if ('undefined' === typeof window.origNetId) { window.origNetId = window.adsNt; }
            if ('undefined' !== typeof window.origNetId) { window.adSetNetId(window.origNetId); }
            
          }

          adsDiv.reloadCount = 0;
          var recoveryId = '';
          var needsRecovery = recoveryId && recoveryId.length && kraken__adBlock && kraken__adBlock.active;
          var adId = needsRecovery ? recoveryId : '93314182';
          // try { adId = io_c3sd.ads["right_rail_flex"] || adId; } catch(e) {}

          
          

          // Override adtech_call_type
          var delivery_type = "default" || "";
          var adtech_call_type = "";
          switch (delivery_type) {
            case "by_request": adtech_call_type = "ajax"; break;
            case "text": adtech_call_type = "text"; break;
            case "iframe": adtech_call_type = "iframe"; break;
            case "iframe_proxy": adtech_call_type = "f"; break;
            case "collapsed": adtech_call_type = "fc"; break;
            default: adtech_call_type = defaultDelivery; break;
          }

          
          
          

          
              
          

          var args = ['RR', 'RR'
          ];

          
          

          
          
          

          

          if(needsRecovery) {
            waitForGlobal('readyToRecover', function() {
              adsDiv = document.querySelector('.right_rail_flex');
              //htmlAdWH(adId, args[0], args[1], "fileless", adsDiv);
            });
          } else {
            console.log('calling MN ' + adId.toString());
            _uacModuleDebug("Element > [right_rail_flex : "+ adId +": "+ args[0] +","+ args[1] +"]");
            htmlAdWH(adId, args[0], args[1], adtech_call_type, adsDiv);
            if (!disableAdRotation) {
              adsRotateMult(adsDiv);
            }
          }

          if (typeof debugadcode == 'function') { debugadcode('AdTech', {placement: 'right_rail_flex', mnid: adId}, adsDiv); }

          waitForGlobal('jQuery', function() {
            jQuery(document).on('reloadAd', function(ev, elem) {
              if (elem && !elem.contains(adsDiv)) { return; }
              var refreshRate = 1;
              adsDiv.reloadCount++;
              if (adsDiv.reloadCount % refreshRate === 0 && typeof adsReloadAd === 'function') { adsReloadAd(adsDiv); }
            });
          });

          if ( !window.__adtechForceInView ) {
            console.log('adSetInView(0)');
            _uacModuleDebug("adSetInView('0') Changed back to 0 probably for next Ad call > [right_rail_flex : " + adId + "]");
            adSetInView('0');
          }

          
        }); // wFG:htmlAdWH
      
    
   //modulous queue closing
}());
</script></div>
</div>









<div class="placement-sponsorship"></div>
<div class="yr-trending js-right-rail-trending"></div>
<div id="right-rail-newsletter"></div>




<div class="advertisement right_rail_300x250_lower" data-placement="right_rail_300x250_lower" data-yaft-module="huffpost-right_rail_300x250_lower">
<div id="ad_right_rail_300x250_lower" class="ad_wrapper_">
<div id="adtech_right_rail_300x250_lower" class="adtech-adspot ad-right_rail_300x250_lower"></div>

<script>
(function() {
  var disableAdRotation = "" === "1";
  var adsDiv = document.querySelector('#adtech_right_rail_300x250_lower');
  adsDiv.removeAttribute('id');

  var defaultDelivery = "f";
  

  
  
  // enableQueue: ""
 
    
      
        waitForGlobal(function() {
          return window.htmlAdWH && window.adSetSyncCalled;
        }, function() {
          // override adsPl in template
          if ('function' === typeof window.adSetPlId) {
            if ('undefined' === typeof window.origAdsPlId) { window.origAdsPlId = window.adsPl; }
            if ('undefined' !== typeof window.origAdsPlId) { window.adSetPlId(window.origAdsPlId); }
            
          }

          // override ads NetId in template
          if ('function' === typeof window.adSetNetId) {
            if ('undefined' === typeof window.origNetId) { window.origNetId = window.adsNt; }
            if ('undefined' !== typeof window.origNetId) { window.adSetNetId(window.origNetId); }
            
          }

          adsDiv.reloadCount = 0;
          var recoveryId = '';
          var needsRecovery = recoveryId && recoveryId.length && kraken__adBlock && kraken__adBlock.active;
          var adId = needsRecovery ? recoveryId : '93432976';
          // try { adId = io_c3sd.ads["right_rail_300x250_lower"] || adId; } catch(e) {}

          
          

          // Override adtech_call_type
          var delivery_type = "default" || "";
          var adtech_call_type = "";
          switch (delivery_type) {
            case "by_request": adtech_call_type = "ajax"; break;
            case "text": adtech_call_type = "text"; break;
            case "iframe": adtech_call_type = "iframe"; break;
            case "iframe_proxy": adtech_call_type = "f"; break;
            case "collapsed": adtech_call_type = "fc"; break;
            default: adtech_call_type = defaultDelivery; break;
          }

          
          
          

          

          var args = ['RR', 'RR'
          ];

          
          

          
          
          

          

          if(needsRecovery) {
            waitForGlobal('readyToRecover', function() {
              adsDiv = document.querySelector('.right_rail_300x250_lower');
              //htmlAdWH(adId, args[0], args[1], "fileless", adsDiv);
            });
          } else {
            console.log('calling MN ' + adId.toString());
            _uacModuleDebug("Element > [right_rail_300x250_lower : "+ adId +": "+ args[0] +","+ args[1] +"]");
            htmlAdWH(adId, args[0], args[1], adtech_call_type, adsDiv);
            if (!disableAdRotation) {
              adsRotateMult(adsDiv);
            }
          }

          if (typeof debugadcode == 'function') { debugadcode('AdTech', {placement: 'right_rail_300x250_lower', mnid: adId}, adsDiv); }

          waitForGlobal('jQuery', function() {
            jQuery(document).on('reloadAd', function(ev, elem) {
              if (elem && !elem.contains(adsDiv)) { return; }
              var refreshRate = 1;
              adsDiv.reloadCount++;
              if (adsDiv.reloadCount % refreshRate === 0 && typeof adsReloadAd === 'function') { adsReloadAd(adsDiv); }
            });
          });

          if ( !window.__adtechForceInView ) {
            console.log('adSetInView(0)');
            _uacModuleDebug("adSetInView('0') Changed back to 0 probably for next Ad call > [right_rail_300x250_lower : " + adId + "]");
            adSetInView('0');
          }

          
        }); // wFG:htmlAdWH
      
    
   //modulous queue closing
}());
</script></div>
</div>


</div>

</div>

<div id="taboola-below-entry-common">
<script class="taboola-ad-script-template" type="text/template">

</script>
</div>
</article>


<div class="below-entry">
<div class="js-bottom-most-shared" id="bottom-most-shared"></div>
<div class="js-bottom-trending" id="bottom-trending"></div>
</div>
<section class="entry__comments-pane js-comment-pane yr-comments-pane">
<div class="entry__comments-pane__close js-comment-close yr-close yr-track"></div>
<h5 class="below-entry-recirc__conversations-header">CONVERSATIONS</h5>
<div class="comments" id="comments">
<script async data-post-id="5ec31ec4c5b6b973546ff05e" data-post-url="https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e" data-spotim-module="spotim-launcher" id="comment-script"></script>
</div>

</section>


</div>
<div class="voting-toaster js-voting-toaster hidden yr-voting-toaster">
<div class="voting-toaster__inner">
<div class="voting-toaster__left">
<img alt="2020 Election" class="voting-toaster__image" src="https://img.huffingtonpost.com/asset/5d88f91b2100003200dab6d8.png">
<div class="voting-toaster__text">
<div class="voting-toaster__title">Today is National Voter Registration Day!</div>
<div class="voting-toaster__subtitle">We made it easy for you to exercise your right to vote!</div>
</div>
</div>
<a class="voting-toaster__button js-voting-toaster-button" href="https://huffpost.turbovote.org/" target="_blank">Register Now!</a>
<div class="voting-toaster__close js-voting-toaster-close yr-track yr-voting-toaster-close"></div>
</div>
</div>


<!-- Footer -->
<footer class="footer yr-footer">


<!-- begin gemini flurry modulous insert -->
<script type="text/javascript">
  console.log("registering 50b9b9b4-1f4f-4c41-94e8-dc7e6dd30814 on target .js-bottom-most-shared .card.recirc__item:eq(1)");
  window.__yahooFlurry.register("50b9b9b4-1f4f-4c41-94e8-dc7e6dd30814");
  waitForGlobal(function() {
    return window.jQuery && window.jQuery(".js-bottom-most-shared .card.recirc__item:eq(1)").length > 0;
  }, function() {
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.adUnitCode = w_yahoo.adUnitCode || [];
    w_yahoo.adUnitCode.push("50b9b9b4-1f4f-4c41-94e8-dc7e6dd30814");
    var $yahooDiv = $("<div id=\"polar-gemini-most-shared\"></div>");
    if ( "replace" === "insertBefore" || "replace" === "replace" ) {
      $yahooDiv.insertBefore(".js-bottom-most-shared .card.recirc__item:eq(1)");
      if ( "replace" === "replace" ) {
        window.__yahooFlurry.addToCleanup("50b9b9b4-1f4f-4c41-94e8-dc7e6dd30814", "polar-gemini-most-shared", $(".js-bottom-most-shared .card.recirc__item:eq(1)")[0].outerHTML);
        $(".js-bottom-most-shared .card.recirc__item:eq(1)").remove(); 
      }
    } else {
      $yahooDiv.insertAfter(".js-bottom-most-shared .card.recirc__item:eq(1)");
    }
    window.__yahooFlurry.ready("50b9b9b4-1f4f-4c41-94e8-dc7e6dd30814");
  });
</script><!-- begin gemini flurry modulous insert -->
<script type="text/javascript">
  console.log("registering 2e63d6ca-115c-4d45-8b46-bdb10c4f0a97 on target .js-bottom-trending .card.recirc__item:eq(1)");
  window.__yahooFlurry.register("2e63d6ca-115c-4d45-8b46-bdb10c4f0a97");
  waitForGlobal(function() {
    return window.jQuery && window.jQuery(".js-bottom-trending .card.recirc__item:eq(1)").length > 0;
  }, function() {
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.adUnitCode = w_yahoo.adUnitCode || [];
    w_yahoo.adUnitCode.push("2e63d6ca-115c-4d45-8b46-bdb10c4f0a97");
    var $yahooDiv = $("<div id=\"polar-gemini-whats-hot-2\"></div>");
    if ( "replace" === "insertBefore" || "replace" === "replace" ) {
      $yahooDiv.insertBefore(".js-bottom-trending .card.recirc__item:eq(1)");
      if ( "replace" === "replace" ) {
        window.__yahooFlurry.addToCleanup("2e63d6ca-115c-4d45-8b46-bdb10c4f0a97", "polar-gemini-whats-hot-2", $(".js-bottom-trending .card.recirc__item:eq(1)")[0].outerHTML);
        $(".js-bottom-trending .card.recirc__item:eq(1)").remove(); 
      }
    } else {
      $yahooDiv.insertAfter(".js-bottom-trending .card.recirc__item:eq(1)");
    }
    window.__yahooFlurry.ready("2e63d6ca-115c-4d45-8b46-bdb10c4f0a97");
  });
</script><!-- begin gemini flurry modulous insert -->
<script type="text/javascript">
  console.log("registering 8d56971c-e73b-4a08-8f94-26ce0a000e70 on target .js-bottom-trending .card.recirc__item:eq(5)");
  window.__yahooFlurry.register("8d56971c-e73b-4a08-8f94-26ce0a000e70");
  waitForGlobal(function() {
    return window.jQuery && window.jQuery(".js-bottom-trending .card.recirc__item:eq(5)").length > 0;
  }, function() {
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.adUnitCode = w_yahoo.adUnitCode || [];
    w_yahoo.adUnitCode.push("8d56971c-e73b-4a08-8f94-26ce0a000e70");
    var $yahooDiv = $("<div id=\"polar-gemini-whats-hot-7\"></div>");
    if ( "replace" === "insertBefore" || "replace" === "replace" ) {
      $yahooDiv.insertBefore(".js-bottom-trending .card.recirc__item:eq(5)");
      if ( "replace" === "replace" ) {
        window.__yahooFlurry.addToCleanup("8d56971c-e73b-4a08-8f94-26ce0a000e70", "polar-gemini-whats-hot-7", $(".js-bottom-trending .card.recirc__item:eq(5)")[0].outerHTML);
        $(".js-bottom-trending .card.recirc__item:eq(5)").remove(); 
      }
    } else {
      $yahooDiv.insertAfter(".js-bottom-trending .card.recirc__item:eq(5)");
    }
    window.__yahooFlurry.ready("8d56971c-e73b-4a08-8f94-26ce0a000e70");
  });
</script>
<script>
window.addEventListener('load', function() {
  var ref = document.getElementsByTagName("script")[0];
  var script = document.createElement("script");
  script.src = 'https://s.skimresources.com/js/38395X1559799.skimlinks.js';
  script.async = true;
  ref.parentNode.insertBefore(script, ref);
}, false);
</script>

<!-- begin yahoo flurry footer bootstrap -->
<script type="text/javascript">
  waitForGlobal(function(){
    return window.__yahooFlurry.isReady();
  }, function() {
    console.log("loading flurry yap.js");
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.apiKey = "NZQB268N5MHYSQTVQ8D2";
    
    (function(){
      var script = d_yahoo.createElement("script");
      // script.async = true;
      if ( "" ) {
        script.src = "";
      } else {
        script.src = "https://s.yimg.com/av/yap/ga/yap.js";
      }
      script.onload = function() {
        console.log('yap.js loaded');
        console.log('adUnitCode', w_yahoo.adUnitCode);
      };
      d_yahoo.body.appendChild(script);
      window.console.log(w_yahoo.adUnitCode);
      window.__yahooFlurry.cleanup();
    })();
  });
</script>
<script>
    window._taboola = window._taboola || [];
    _taboola.push({flush:true});
</script>
<div class="footer__wrapper">
<div class="footer__top">
<div class="footer__logo">
<a class="yr-logo-image" href="https://www.huffpost.com">
<img alt="HuffPost" class="footer__img large" src="https://s.m.huffpost.com/assets/HuffPostHero-d783f680fb974e80346bdfa145131d058e596e1d32f791981875aa481702c770.svg">
<img alt="HuffPost" class="footer__img small" src="https://s.m.huffpost.com/assets/H-icon-72fd5782b36a1a42ab82a4af65cbc6dd6ddc4d4a71190a91c5cfaab7c66fd836.svg">
</a>
</div>
<ul class="footer__list sections">
<li class="footer__item">
<a class="footer__link" href="/news/" target="">News</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/news/politics" target="">Politics</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/entertainment/" target="">Entertainment</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/life/" target="">Life</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/voices/" target="">Communities</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/section/huffpost-personal" target="">HuffPost Personal</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/section/video" target="">Video</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/newsletters" target="">Newsletters</a>
</li>
</ul>
<ul class="footer__list corporate">
<li class="footer__item">
<a class="footer__link" href="/" target="">HuffPost</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/about-us" target="">About Us</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.oath.com/brands/huffpost/" target="_blank">Advertise</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://policies.oath.com/us/en/oath/privacy/adinfo/index.html" target="_blank">About Our Ads</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/contact-us" target="">Contact Us</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/syndication" target="">RSS</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/faq" target="">FAQ</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.oath.com/careers/job-openings?q=&amp;jobDepartment=&amp;jobBrand=huff+post&amp;jobCity=" target="_blank">Careers</a>
</li>
<li class="footer__item">
<a class="footer__link" href="/archive" target="">Archive</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://policies.oath.com/us/en/oath/terms/otos/index.html" target="">User Agreement</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://policies.oath.com/us/en/oath/privacy/index.html" target="">Privacy Policy</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/comment-policy" target="">Comment Policy</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/news/topic/press-room" target="">HuffPost Press Room</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://coupons.huffpost.com" target="">Coupons</a>
</li>
</ul>
</div>
<div class="footer__bottom" style="display:flex;justify-content:space-between;"><a href="https://guce.huffpost.com/privacy-dashboard?locale=en-US" id="ccpa-link" style="color:currentColor;">Privacy dashboard<img src="https://s.yimg.com/cv/apiv2/default/20200109/Privacy_Rights_icon.png" width="13.23" height="13" alt="" style="margin-left:2px;vertical-align:middle;" /></a>
<div class="footer__copyright">Part of HuffPost Entertainment. ©2020 Verizon Media. All rights reserved. Huffington Post.</div>
</div>
</div>
</footer>


<div class="yr-slideshow-desktop">

</div>
<div class="modal hidden yr-modal" id="modal">
<div class="modal__inner">
<div class="modal__close yr-close yr-track"></div>
<div class="modal__content yr-modal-body"></div>
</div>
</div>

<script>
  HP.functions.loadCSS('https://s.m.huffpost.com/assets/desktop-bef4b1613dcff8c99fc019d564183e666c2f7d5a0307075fdb8bd9beca20a396.css');
</script>
<div class="tracking-data">
<script>
  window.comscore_data = {"c1":2,"c2":6723616,"c3":"","c4":"/us/entry/5ec31ec4c5b6b973546ff05e","c5":"entertainment","c6":"","c15":"","options":{"url_append":"comscorekw=entertainment"}};
  window.comscore_data.c4 = location.protocol+"//"+location.host+window.comscore_data.c4;
</script>

<script>
  window.yahooDotConfig = {"projectId":"10000","properties":{"pixelId":"428726","qstrings":{"site":"HuffPost","ec":"entertainment","el":"entertainment","ev":"obit|twilight-film|gregory-tyree-boyce","pt":"content","pct":"story"}}};
</script>


</div>
<div class="tracking">
<script>
  waitForGlobal(function() {
    return !!window.HP.modules.Tracky;
  }, function() {
    window.HP.modules.Tracky.comscore(window.comscore_data);
  })
</script>

<script>
  waitForGlobal(function() {
    return !!window.HP.modules.Tracky;
  }, function() {
    window.HP.modules.Tracky.yahooDot('page_view');
  });
</script>


</div>
<script>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</script>
<script>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</script>

<script src="https://s.m.huffpost.com/assets/desktop-9f0b52e68fe09087b5457523705501332e8a6f364a014def841c1b284ff7db24.js"></script>
<script>
  (function() {
    window.HP.params.entry = {
      id: "5ec31ec4c5b6b973546ff05e",
      tags: ["obit", "twilight-film", "gregory-tyree-boyce"],
      title: "'Twilight' Actor Gregory Tyree Boyce Dead At 30",
      excerpt: "“Twilight” actor Gregory Tyree Boyce has died at age 30. The actor and his girlfriend, Natalie Adepoju, 27, were found dead in a Las Vegas condo on ...",
      url: "https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e",
      canonicalUrl: "https://www.huffpost.com/entry/gregory-tyree-boyce-death_n_5ec31ec4c5b6b973546ff05e",
      author: "Josephine Harvey",
      edition: "us",
      useCommentSSO: true,
      isAnyContributor: false
    };
    window.HP.params.preview = ("" === "true");
    window.HP.params.isWide = ("false" === "true");
    window.HP.params.isAthena = ("true" === "true");
    var isLong = 450 <= ($('.js-entry-body').height() / 2.5);
    window.HP.events.publish("entry_opened", {entry: document.querySelector('article'), isLong: isLong});
  }());
</script>

<script async src="https://apis.google.com/js/platform.js"></script>

<div class="tracking-init">
<div id="vanitydiv" style="visibility:hidden; height: 0px;"></div>
<!-- Begin comScore Tag -->
<script>
  var prefix = (document.location.protocol == "https:" ? "https://sb" : "http://b");
  var script = document.createElement("script");
  script.src = prefix + ".scorecardresearch.com/beacon.js";
  script.async = true;
  script.onload = function() {
    if (window.__cmp) {
      window.__cmp('getVendorConsents', null, function(cmpData, cmpSuccess) {
        window.waitForGlobal('__uspapi', function() {
          window.__uspapi( 'getDoNotSell', 1, (uspData, uspSuccess) => {
            if ( cmpSuccess && cmpData && cmpData.gdprApplies && cmpData.vendorConsents ) {
              window.comscore_data.cs_ucfr = cmpData.vendorConsents[77] ? 1 : 0; // 77 is comscore's vendor id
            } else if ( uspSuccess && uspData && uspData.hasOwnProperty('doNotSell') ) {
              // "doNotSell === true" => user has opted out of letting us sell their info
              // "doNotSell === false" => user hasn't opted out
              window.comscore_data.cs_ucfr = uspData.doNotSell ? 0 : 1;
            }
            window.HP.events.publish('tracking_loaded_comscore');
          });
        });
      });
    } else {
      window.HP.events.publish('tracking_loaded_comscore');
    }
  };
  document.querySelector('.tracking').appendChild(script);
</script>
<noscript>
<img alt="" height="1" src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6723616&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cj=1" width="1">
</noscript>
<!-- End comScore Tag -->

<script>
  (function(d){
    var s = document.createElement('script');
    s.src='https://s.yimg.com/wi/ytc.js';
    s.async=true;
    s.onload = function() {
      window.HP.events.publish('tracking_loaded_yahoo_dot');
    };
    (d.getElementsByTagName('head')[0] ||
     d.getElementsByTagName('body')[0]).appendChild(s);
  })(document);
</script>

<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
  n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1621685564716533'); // Edition specific
  fbq('init', '1043018625788392'); // Partner Studio
  fbq('track', "PageView");
  fbq('track', 'ViewContent', {"content_name":"'Twilight' Actor Gregory Tyree Boyce Dead At 30","content_category":"us.hpmgent"} );
  fbq('trackCustom', 'EntryPage', {"section_name":"Entertainment","tags":["obit","twilight-film","gregory-tyree-boyce"],"team":"us_huffpost_now","ncid":null,"environment":"desktop","render_type":"web"} );
  waitForGlobal(function() {
    return HP.modules.Tracky;
  }, function() {
    /* TODO do we still want this?
    $('body').on('click', function(event) {
      HP.modules.Tracky.reportClick(event, function(data) {
        fbq('trackCustom', "Click", data);
      });
    });
    */
  });
</script>
<noscript>
<img height="1" src="https://www.facebook.com/tr?id=1621685564716533&amp;ev=PageView&amp;noscript=1" style="display:none" width="1">
<img height="1" src="https://www.facebook.com/tr?id=10153394098876130&amp;ev=PageView&amp;noscript=1" style="display:none" width="1">
</noscript>
<!-- End Facebook Pixel Code -->

<script async defer src="https://s.yimg.com/ss/vops.js" type="text/javascript"></script>


</div>
<script>
  HP.functions.init();
  window.addEventListener('load', modulousQueue.runAll);
</script>
<script>
  window.HP.events.subscribe('init_dom_ready', function() {
    waitForGlobal(function(){
      return window.HP && window.$;
    }, function() {
      $(".js-header-content-left .header__search").removeClass("hidden");
      var sdk = document.createElement('script');
      sdk.src = 'https://s.yimg.com/pv/static/assistjs/desktop-v1.0.70.js';
      sdk.id = "assistjs";
      sdk.async = true;
      sdk.onload = function() {
        window.YAHOO.SA.init({
          saBE: {
            params: {
              appid: 'search.huffpost.com'
            },
            host: '//search.huffpost.com',
            base: '/sugg/gossip/gossip-us-huffpost/'
          },
          elems: {
            'sbForm' : 'header-search-form',
            'sbInput': 'header-search-input'
          },
          plugins: {
            saTray: {
              parent: 'header-search-results'
            },
            saFr: {
              def: 'huffpost',
              fr: 'huffpost-s'
            }
          }
        });
      }
      document.body.appendChild(sdk);
    });
  });
</script>


<!--[if IE]>
<link rel="stylesheet" media="screen" href="https://s.m.huffpost.com/assets/ie-3d19a68f6b6f10d1a1f82dfae355483d08205e66b959611e370d50e21c19d841.css" />
<![endif]-->
</div>
</div>
</body>
</html>
