<!DOCTYPE html>
<html lang="en">
<head>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"a2134792db","applicationID":"36240457","transactionName":"dApeRxcOWV5RFB1SA0QORFwVTlBcQBRbUxUYFlhcEg==","queueTime":2,"applicationTime":51,"agent":"","atts":"TEdFEV8aF1dQD0ZfCVlHChEQEhceFhVXVRJeCl4RX0NjW1ADXUVEShg="}</script>
<script type="text/javascript">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</script>
<meta content="97Mj-wW7u8U1NOnkW1rfH-I1kgO0-a9YsgoesOk41R8" name="google-site-verification">
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script async="true" type="text/javascript">
(function() {
  function getHost() {
    var host = window.location.hostname;
    var r = host.match(/.*\.((huffingtonpost|huffpostbrasil|huffpost)\.(co\.uk|com\.au|co\.za|com\.mx|ca|de|es|fr|gr|in|it|jp|kr|com))/);
    if(r && r.length && r.length >= 2) {
      return r[1];
    } else {
      return host;
    }
  }

  var host = getHost();
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://quantcast.mgr.consensu.org'.concat('/choice/', '3aud4J6uA4Z6Y', '/', host, '/choice.js');
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;
  firstScript.parentNode.insertBefore(element, firstScript);
  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;
    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);
      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');
          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }
    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;
      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };
        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        queue.push(args);
      }
    }
    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};
      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}
      var payload = json.__tcfapiCall;
      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            event.source.postMessage(returnMsg, '*');
          },
          payload.parameter
        );
      }
    }
    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}
      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  }
  makeStub();
  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };
  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }

  if (host === 'huffpost.com') {
    window.__uspapi("uspPing", 1, function (obj, status) {
      if (status && obj.mode.includes("USP") && obj.jurisdiction.includes(obj.location.toUpperCase())) {
        document.getElementById('ccpa-link-container').innerHTML =
          '<a href="javascript:window.__uspapi(\'displayUspUi\');" id="ccpa-link">Do Not Sell My Personal Information<img src="https://modulous.huffpost.com/2021/01/12/1610491229-Privacy_Rights_icon.png" width="13.23" height="13" alt="" style="margin-left:2px;vertical-align:middle;" /></a>';
      }
    });
  }
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script async="true" type="text/javascript">
(function checkConsentParams(){
  function __log(m) { return window.console && console.log('[BuzzFeed(CMP)] > ' + m); }
  function getParameterByName(name) {
    var url = window.location.href;
    name = name.replace(/[\[\]]/g, '\\$&');
    var regex = new RegExp('[?&]' + name + '(=([^&#]*)|&|#|$)'),
        results = regex.exec(url);
    if (!results) return null;
    if (!results[2]) return '';
    return decodeURIComponent(results[2].replace(/\+/g, ' '));
  }

  var consentQueryParam = getParameterByName('display-consent') || '';
  __log('display-consent param: ' + consentQueryParam);
  if (['gdpr', 'ccpa'].indexOf(consentQueryParam) !== -1) {
    window.__tcfapi('addEventListener', 2, function (tcData, success) {
      if (success && tcData.eventStatus !== 'cmpuishown' && tcData.eventStatus !== 'useractioncomplete') {
        __log('GDPR applies: ' + tcData.gdprApplies);
        if (consentQueryParam === 'gdpr' && tcData.gdprApplies) {
          __log('Calling displayConsentUi: ' + typeof window.__tcfapi);
          window.__tcfapi('displayConsentUi', 2, function() {});
        } else if (consentQueryParam === 'ccpa' && !tcData.gdprApplies) {
          __log('Calling displayUspUi: ' + typeof window.__uspapi);
          window.__uspapi('displayUspUi');
        }
      } else {
        __log('Failed');
      }
    });
  }
  return;
}());
</script>

<script>
  // critical desktop
  window.HP=window.HP||{},HP.modules=HP.modules||{},HP.functions=HP.functions||{},HP.elements=HP.elements||{},HP.params=HP.params||{},HP.modules.ads={banner:"",square:"",promotion:""},window.HP.functions.isEmpty=function(n){for(var t in n)if(n.hasOwnProperty(t))return!1;return!0},window.MW=HP,window.Mobileweb=HP.modules,function(n){var e=function(n,t){var e=new RegExp("[?&]"+t+"(=(.*?))?(&|$)","i"),r=n.match(e);if(r)return r[2]||""},t=function(n,t){return void 0!==e(n,t)};n.getQueryStringParameter=e,n.isQueryStringParameterPresent=t}(HP.functions),HP.modules.storage=function(){var n,t,e,r,i,o,a,s,u;return o=function(){try{var n="test";return(a=window.localStorage).setItem(n,"1"),a.removeItem(n),!0}catch(t){return!1}}(),u=function(n){if("string"!=typeof n)return undefined;try{return JSON.parse(n)}catch(t){return n||undefined}},s=function(n){return JSON.stringify(n)},o?(n=function(n){return u(a.getItem(n))},t=function(n,t){try{a.setItem(n,s(t))}catch(e){}},e=function(n){a.removeItem(n)},r=function(){a.clear()},i=function(n){return a.getItem(n)!==undefined}):(n=t=e=r=function(){},i=function(){return!1}),{enabled:o,get:n,set:t,remove:e,clear:r,has:i}}(),function(){function a(n){var t="",e=window.location.href,r=window.HP.functions.getQueryStringParameter(window.location.href,"ab"),i=window.HP.functions.getQueryStringParameter(window.location.href,"g");return r===undefined||i===undefined||r!==n||-1===e.indexOf("staging")&&-1===e.indexOf("local")&&-1===e.indexOf("design")||f[r]&&f[r].variants[i]&&(t=i),t}function s(n,t){if(f[n]){var e=f[n].id,r=f[n].variants[t];r===undefined&&console.error("Could not find AB test variant for value",t),d(n,e,t,r)}else console.error("Could not find AB test",n)}function u(n){var t=Object.keys(f[n].variants),e=f[n].distribution;return e?r(t,e):t[Math.floor(Math.random()*t.length)]}function r(n,t){for(var e=0,r=Math.random(),i=0;i<n.length;i++)if(r<=(e=+(e+=t[i]).toFixed(2)))return n[i]}function e(n){if(localStorage.getItem("abTest-"+n))return JSON.parse(localStorage.getItem("abTest-"+n)).value}function i(n,t){v[n]=t;var e=localStorage["abTest-"+n];(void 0===e||e.date+w<Date.now())&&m.set("abTest-"+n,{value:t,date:Date.now()})}function o(n){var t=e(n);return t===undefined&&i(n,t=u(n)),t}function d(n,t,e,r){c.push([t,r].join(":")),l.push([n,e].join(":")),i(n,e),window.HP.devMode&&console.log("AB test",n,"set to",e)}var f={},c=[],l=[],m=window.HP.modules.storage,v={};window.HP.modules.AB={set:s,testMap:function(){return c},userGroupTestMap:function(){return Object.keys(f).map(function(n){var t=f[n].id,e=f[n].variants[o(n)];if(t!==undefined&&e!==undefined)return t+":"+e})},namedTestMap:function(){return l},registerTest:function(n,t,e,r){if(!((r=r||{}).platforms&&-1===r.platforms.indexOf(HP.params.device)||r.editions&&-1===r.editions.indexOf(HP.params.edition.id)))return f[n]={id:t,variants:e},r.distribution&&(f[n].distribution=r.distribution),f[n]},sample:function(n,t){if(!f[n])return undefined;var e=t;if(v[n])return v[n];var r=a(n);if(""!==r)e=r;else if(m.enabled||t===undefined){var i="abTest-"+n,o=m.get(i);e=o&&Date.now()<o.date+w?o.value:u(n)}return s(n,e),e},sampleAnonymous:function(n,t){var e="anonymous-"+n;if(v[e])return v[e];var r=t[Math.floor(Math.random()*t.length)];if(m.enabled){var i="abTest-"+e,o=m.get(i);o&&Date.now()<o.date+w&&(r=parseInt(o.value,10))}return d(e,n,r,r),r}};var w=6048e5,g=HP.modules.AB;HP.params&&HP.params.ab_config&&HP.params.ab_config.forEach(function(n){var e={},r=n.variant_ids.split(","),t=n.variant_distributions.split(",").map(function(n){return parseFloat(n)});n.variant_names.split(",").forEach(function(n,t){e[n]=parseInt(r[t])}),g.registerTest(n.name,parseInt(n.id),e,{distribution:t})})}(),function(){var n=window.HP.modules.AB;n.registerTest("appDownloadEntryInterstitial-2",1037,{firstToKnow:109,storiesThatMatter:110}),n.registerTest("appDownloadModalFrontAndroid2",1041,{hide:121,showEntertainmentVerticalImage:122},{distribution:[.85,.15]}),n.registerTest("appDownloadModalFrontiOS2",1042,{hide:124,showEntertainmentVerticalImage:125},{distribution:[.85,.15]}),n.registerTest("slideshowCard",1036,{control:106,overlay:107,grid:108}),n.registerTest("huffpostPlusMidEntryCta3",1049,{a:142,b:143,c:144})}();
</script>
<meta content="18468761129" property="fb:pages">
<meta content="56845382910" property="fb:pages">
<meta content="115699328440194" property="fb:pages">
<meta content="202163013203224" property="fb:pages">
<meta content="63096571313" property="fb:pages">
<meta content="217254191630265" property="fb:pages">
<meta content="70072372362" property="fb:pages">
<meta content="10018702564" property="fb:pages">
<meta content="159156871082" property="fb:pages">
<meta content="218821728150273" property="fb:pages">
<meta content="215547491837032" property="fb:pages">
<meta content="271573749521209" property="fb:pages">
<meta content="256004367748633" property="fb:pages">
<meta content="565494996987624" property="fb:pages">
<meta content="328537730839840" property="fb:pages">
<meta content="335527613514005" property="fb:pages">
<meta content="928754893893780" property="fb:pages">
<meta content="1254930621269234" property="fb:pages">
<meta content="1242860892501019" property="fb:pages">
<meta content="131149920304237" property="fb:pages">
<meta content="70242384902" property="fb:pages">
<meta content="max-image-preview:large" name="robots">

<title>Reactions To Trump’s Primetime Address | HuffPost</title>
<meta charset="utf-8">
<meta content="width=device-width, initial-scale=1.0, minimum-scale=1.0" name="viewport">
<meta content="Here’s how pundits, politicians and comedians reacted to President Donald Trump’s address to the nation." name="description">
<meta content="Donald Trump,Politics,media,HuffPost News,News, shutdown,the wall" name="keywords">
<meta content="Reactions To Trump’s Primetime Address" property="og:title">
<meta content="video" property="og:type">
<meta content="https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000" property="og:image">
<meta content="https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000" property="og:image:url">
<meta content="image/jpeg" property="og:image:type">
<meta content="1778" property="og:image:width">
<meta content="1000" property="og:image:height">
<meta content="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" property="og:url">
<meta content="HuffPost" property="og:site_name">
<meta content="en_US" property="og:locale">
<meta content="Here’s how pundits, politicians and comedians reacted to President Donald Trump’s address to the nation." property="og:description">
<meta content="Donald Trump,Politics,media,HuffPost News,News, shutdown,the wall" property="article:tag">
<meta content="Videos" property="article:section">
<meta content="summary_large_image" name="twitter:card">
<meta content="@" name="twitter:site">
<meta content="Reactions To Trump’s Primetime Address" property="twitter:title">
<meta content="https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000" property="twitter:image">
<meta content="1778" property="twitter:image:width">
<meta content="1000" property="twitter:image:height">
<meta content="Here’s how pundits, politicians and comedians reacted to President Donald Trump’s address to the nation." property="twitter:description">
<meta content="2019-01-09 10:20:47 -0500" property="article:published_time">
<meta content="2019-01-09 10:20:47 -0500" property="article:modified_time">
<meta content="huffpostnews:///?editionID=us&amp;entryID=us_5c36122fe4b07c260cd0fdb1" property="al:ios:url">
<meta content="306621789" property="al:ios:app_store_id">
<meta content="HuffPost" property="al:ios:app_name">
<link href="ios-app://306621789/huffpostnews/?editionID=us&amp;entryID=us_5c36122fe4b07c260cd0fdb1" rel="alternate">

<meta content="46744042133" property="fb:app_id">
<meta content="text/html" http-equiv="Content-Type">
<meta content="IE=Edge,chrome=1" http-equiv="X-UA-Compatible">
<link rel="shortcut icon" type="image/x-icon" href="https://s.m.huffpost.com/assets/favicon-2020e123c064086aad150fe909c53771f862d7c76cd62f6146e81d533845fd7d.ico" />
<link href="//m.huffpost.com/us/entry/us_5c36122fe4b07c260cd0fdb1" media="handheld" rel="alternate">
<link href="//m.huffpost.com/us/entry/us_5c36122fe4b07c260cd0fdb1" media="only screen and (max-width: 640px)" rel="alternate">
<link href="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" rel="canonical">
<link href="http://m.huffpost.com/us/entry/us_5c36122fe4b07c260cd0fdb1/amp" rel="amphtml">
<style>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</style>
<link href="https://fonts.googleapis.com/css?family=Montserrat:700,800,800i" rel="stylesheet">
<script>
  (function(){
    window.HP || (window.HP = {});
    HP.params = {"device":"desktop","edition":{"id":"us"},"ab_config":[{"name":"outstreamStyle","id":1002,"variant_names":"control,enabled","variant_ids":"11,12","variant_distributions":"0.75,0.25"},{"name":"outstreamParents","id":1001,"variant_names":"control,enabled","variant_ids":"9,10","variant_distributions":"0.75,0.25"},{"name":"outstreamPolitics","id":1000,"variant_names":"control,enabled","variant_ids":"7,8","variant_distributions":"0.75,0.25"},{"name":"vidibleOnHomepage2","id":91,"variant_names":"noVideo,autoPlayWithoutSound","variant_ids":"136,137","variant_distributions":"0.8,0.2"},{"name":"homepageSplash","id":1008,"variant_names":"control,splash","variant_ids":"26,27","variant_distributions":"0.5,0.5"},{"name":"videoBelowSplash100Percent","id":92,"variant_names":"video","variant_ids":"138","variant_distributions":"1.0"},{"name":"mfp1829","id":1010,"variant_names":"embed,embedFlip,autoPlayWithoutSound","variant_ids":"31,32,33","variant_distributions":"0.4,0.4,0.2"}],"staging":false};
  
    var csrfToken = 'eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJ1cmwiOiIvZW50cnkvcmVhY3Rpb25zLXRvLXRydW1wcy1wcmltZXRpbWUtYWRkcmVzc19uXzVjMzYxMjJmZTRiMDdjMjYwY2QwZmRiMSIsImlhdCI6MTYzMDI0MTY4NiwiZXhwIjoxNjMwMjQ4ODg2fQ.DyrQRl9NyqrXt7g0myEkW3gRU7gxfexFEjJvLWyQuH0'.replace(/\{\{__HP[-]CSRF[-]TOKEN__\}\}/, '');
    HP.params.csrfToken = csrfToken ? csrfToken : null;
  }());
</script>

<script>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</script>
<script>
  window.HP.functions.loadFont('ProximaNovaCond', 'https://s.m.huffpost.com/assets/fonts/proxima-nova-condensed-00413bf3c406df7a1c9b6218d92f311ced4bc12564bede72e457e7963bf16f44.css', {
    before: "h1,h2,h3,h4,h5{visibility:hidden;}",
    after: "h1,h2,h3,h4,h5{visibility:visible;}"
  }, 1000);
</script>
<script>
  window.HP.functions.loadFont('ProximaNova', 'https://s.m.huffpost.com/assets/fonts/proxima-nova-8436d7ce85f4132d9836303fd5f328b5132418284edeaa238f9d6a54bf8a767c.css', {
    before: "h1,h2,h3,h4,h5{visibility:hidden;}",
    after: "h1,h2,h3,h4,h5{visibility:visible;}"
  }, 500);
</script>

<script type="application/ld+json">
{"@context":"http://schema.org","dateCreated":"2019-01-09T15:20:47Z","datePublished":"2019-01-09T15:20:47Z","dateModified":"2019-01-09T15:20:47Z","author":{"@context":"http://schema.org","@type":"Person","affiliation":{"@type":"NewsMediaOrganization","name":"HuffPost","url":"https://www.huffpost.com","logo":{"@type":"ImageObject","url":"https://s.m.huffpost.com/assets/hp-amp-101ecf8047b044dce5f3122c63056162580f1c26994c73ae90dbd1c5d1545a71.gif","width":600,"height":60}},"name":"HuffPost Video","jobTitle":"HuffPost Video","description":"HuffPost Video","url":"https://www.huffpost.com/author/huffpost-video"},"creator":{"@context":"http://schema.org","@type":"Person","affiliation":{"@type":"NewsMediaOrganization","name":"HuffPost","url":"https://www.huffpost.com","logo":{"@type":"ImageObject","url":"https://s.m.huffpost.com/assets/hp-amp-101ecf8047b044dce5f3122c63056162580f1c26994c73ae90dbd1c5d1545a71.gif","width":600,"height":60}},"name":"HuffPost Video","jobTitle":"HuffPost Video","description":"HuffPost Video","url":"https://www.huffpost.com/author/huffpost-video"},"publisher":{"@type":"NewsMediaOrganization","name":"HuffPost","url":"https://www.huffpost.com","logo":{"@type":"ImageObject","url":"https://s.m.huffpost.com/assets/hp-amp-101ecf8047b044dce5f3122c63056162580f1c26994c73ae90dbd1c5d1545a71.gif","width":600,"height":60}},"description":"Here’s how pundits, politicians and comedians reacted to President Donald Trump’s address to the nation.","keywords":["donald-trump","politics","media","huffpost-news","news","shutdown","the-wall","@team_us_auto_video","type: news"],"inLanguage":"en_US","thumbnailUrl":"https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg","url":"https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1","headline":"Reactions To Trump’s Primetime Address","image":{"@type":"ImageObject","url":"https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000","width":1778,"height":1000},"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1"},"@type":"VideoObject","name":"Reactions To Trump’s Primetime Address","playerType":"HTML5 Flash","uploadDate":"2019-01-09T15:20:47Z","contentUrl":"http://delivery.vidible.tv/video/redirect/5c36114f367f6d75d97b9eb5.m3u8?bcid=56000e19e4b0e4e194b84b31&w=1920&h=1080&enc=m3u8&domain=cdn.vidible.tv"}

</script>
<!--__HP-SPOT-SCHEMA__-->

<script defer src="https://tagan.adlightning.com/buzzfeed/op.js"></script>
<script defer src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>
  document.addEventListener('DOMContentLoaded', function () {
    Sailthru.init({ customerId: 'ef61ea729b0d2b3168a9ca339d950d91' })
  });
</script>
<script>
  window.__logAtwola = "https://ads-debug.huffpost.com:4443";
</script>
<!-- Ad Header -->

<style type="text/css">
.pg-placeholder.active {
  border-width: 2px 0;
  border-style: solid;
  border-color: #171d67;
  padding: 20px 0;
}
</style>
<!-- begin yahoo flurry header bootstrap -->
<script type="text/javascript">
window.__yahooFlurry = {
  registry: [],
  complete: [],
  remove: {},
  original: {},
  timeout: null,
  cleanupCount: 0,
  register: function(code) {
    this.registry.push(code);
  },
  ready: function(code) {
    this.complete.push(code);
  },
  isReady: function() {
    return this.registry.length === this.complete.length && this.registry.length > 0;
  },
  addToCleanup: function(code, div, originalHtml) {
    this.remove[code] = div;
    this.original[code] = originalHtml;
  },
  cleanup: function() {
    var _this = this;
    this.cleanupCount = this.cleanupCount + 1;
    console.log("cleanup attempt #" + this.cleanupCount.toString());
    this.timeout = setTimeout(function(){
      for ( var i in _this.remove ) {
        if ( _this.remove.hasOwnProperty(i) ) {
          if ( window.jQuery("[code=" + i + "]").length > 0 ) {
            window.jQuery("#" + _this.remove[i]).remove();
            console.log(_this.remove[i]);
            delete _this.remove[i];
          }
        }
      }
      if ( Object.keys(_this.remove).length ) {
        if ( _this.cleanupCount < 50 ) {
          _this.cleanup();
        } else if ( _this.cleanupCount >= 50 ) {
          _this.restoreOriginals();
        }
      }
    }, 100);
  },
  restoreOriginals: function() {
    console.log("restoring");
    console.log(this.remove);
    console.log(this.original);
    for ( var i in this.remove ) {
      if ( this.remove.hasOwnProperty(i) ) {
        var $original = $(this.original[i]);
        $original.insertBefore("#" + this.remove[i]);
        window.jQuery("#" + this.remove[i]).remove();
      }
    }
  }
};
</script>
<script type="text/javascript">
  window.HPGam = window.HPGam || {};
  window.HPGam.cmd = window.HPGam.cmd || [];
  window.googletag = window.googletag || {};
  window.googletag.cmd = window.googletag.cmd || [];

  HPGam.cmd.push(function(){
    var units = [];
    var brandPlatform = ['huffpost'];
    
    brandPlatform.push('desktop');
    
    
    var category = 'unknown';
    
    category = 'video';
    
    

    units.push(
      '6556',
      brandPlatform.join('.'),
      'en',
      category
    );

    HPGam.env.setParams({
      site: "us",
      section: category,
      subSections: [],
      platform: brandPlatform[1],
      platformNames: ["desktop3"],
      pageTypes: ["atf","bpage","news","standard","video"],
      entryId: "5c36122fe4b07c260cd0fdb1",
      tags: ["donald-trump","huffpost-news","media","news","politics","shutdown","the-wall"],
      testAds: [],
      bnp: "",
      adUnits: units
    });

    function targetMap() {
      function csvToArr(str) {
        var str2 = str.replace(/(^\s+|\s+$)/g, '');
        return (str2.length && str2.split(",") || []);
      }
      var r = [];
      function addKV(key, val) {
        if (val.length > 0) {
          r.push([key, val]);
        }
      }
      addKV("destination", "huffpost");
      addKV("edition", "us");
      addKV("hpid", "5c36122fe4b07c260cd0fdb1");
      
      
      
      addKV("zone3", 'video');
      
      
      addKV("pageType", csvToArr("atf,bpage,news,standard,video"));
      addKV("section", csvToArr(""));
      
      addKV("cms_tag", csvToArr("donald-trump,huffpost-news,media,news,politics,shutdown,the-wall"));
      
      addKV("user", csvToArr("huffpost-video"));
      var dfpKeywordVal = HPGam.getQuery("dfp-keyword");
      if (dfpKeywordVal) {
        addKV('dfp-keyword', dfpKeywordVal);
      }
      return r;
    }

    googletag.cmd.push(function(){
      var map = targetMap();
      HPGam.log('setTargeting', map);
      map.forEach(function(t){
        return googletag.pubads().setTargeting(t[0], t[1]);
      });
    });

    return;
  });
</script>




<script type="text/javascript" src="https://modulous.huffpost.com/2021/06/29/1624932465-bundle-gam-oo-de0ac77.min.js" async></script>




<script>
var _HPJS = (function (_mod) {
  "use strict";

  _mod.loadJS = function (src, options) {
    var options = options || {};
    var ref = window.document.getElementsByTagName("script")[0];
    var script = window.document.createElement("script");
    script.src = src;
    script.async = options.async;
    script.defer = options.defer;
    ref.parentNode.insertBefore(script, ref);
    return script;
  }

  _mod.loadJSLater = function (url, timeout) {
    var ran = false;
    var loader = function () {
      if (ran) {
        return;
      }
      ran = true;
      _mod.loadJS(url, {async:true});
    }
    window.addEventListener ?
      window.addEventListener("load",loader,false) :
      window.attachEvent && window.attachEvent("onload",loader);
    // in case the load event never fires
    setTimeout(loader, timeout || 15000);
  }

  _mod.waitForGlobal = function(identifier, cb, poll) {
    var test = typeof identifier === "function" ? identifier : function() { return !!window[identifier]; };
    var interval;
    if(test()) {
      cb();
    } else {
      interval = setInterval(function(){
        if(test()) {
          cb();
          clearInterval(interval);
        }
      }, poll || 50);
    }
  };

  return _mod;

}(_HPJS || {}));
</script>
</head>
<body class="sticky-top-nav-only desktop b-page section--video section-video video" data-locale="en_US">
<div class="body-wrap">
<div id="recaptcha-container"></div>

<div class="advertisement asset_inserts" data-placement="asset_inserts" data-yaft-module="huffpost-asset_inserts">
<script type="text/javascript">
waitForGlobal("adSetMOAT", function() {
  adSetMOAT("1");
});
</script>
</div>



<div class="main">

<!-- Header -->

<div class="left-nav yr-left-nav" role="menu">
<div class="left-nav__body">
<div class="left-nav__top">
<button aria-label="Close Menu" class="left-nav__close yr-track yr-close-hamburger"></button>
<button aria-expanded="false" class="left-nav__editions-menu__toggle js-edition-toggle yr-editions-button yr-track">US Edition</button>
<div class="left-nav__editions-menu js-editions-menu">

<div class="editions-menu editions-menu--leftnav js-editions-menu yr-editions-menu">
<div class="editions-menu__list">
<div class="editions-menu__list__item current">U.S.</div>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="U.K." href="https://www.huffingtonpost.co.uk?country=UK">U.K.</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="España" href="https://www.huffingtonpost.es?country=ES">España</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="France" href="https://www.huffingtonpost.fr?country=FR">France</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Ελλάδα (Greece)" href="https://www.huffingtonpost.gr?country=GR">Ελλάδα (Greece)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Italia" href="https://www.huffingtonpost.it?country=IT">Italia</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="日本 (Japan)" href="https://www.huffingtonpost.jp?country=JP">日本 (Japan)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="한국 (Korea)" href="https://www.huffingtonpost.kr?country=KR">한국 (Korea)</a>
</div>
</div>

<div aria-label="Close editions menu" class="left-nav__editions-menu__close js-edition-toggle yr-editions-close-button yr-track" role="button">CLOSE</div>
</div>
</div>
<div class="left-nav__menu">
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Coronavirus" data-subsec="coronavirus" href="https://www.huffpost.com/feature/coronavirus" target="_self">Coronavirus</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="News" data-subsec="news" href="https://www.huffpost.com/news/" target="_self">News</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="U.S. News" data-subsec="news" href="https://www.huffpost.com/section/us-news" target="_self">U.S. News</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="World News" data-subsec="news" href="https://www.huffpost.com/section/world-news" target="_self">World News</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Business" data-subsec="news" href="https://www.huffpost.com/impact/business" target="_self">Business</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Environment" data-subsec="news" href="https://www.huffpost.com/impact/green" target="_self">Environment</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Health" data-subsec="news" href="https://www.huffpost.com/section/health" target="_self">Health</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Social Justice" data-subsec="news" href="https://www.huffpost.com/impact/topic/social-justice" target="_self">Social Justice</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Politics" data-subsec="politics" href="https://www.huffpost.com/news/politics" target="_self">Politics</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Joe Biden" data-subsec="politics" href="https://www.huffpost.com/news/topic/joe-biden" target="_self">Joe Biden</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Congress" data-subsec="politics" href="https://www.huffpost.com/news/topic/us-congress" target="_self">Congress</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Extremism" data-subsec="politics" href="https://www.huffpost.com/news/topic/extremism" target="_self">Extremism</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Entertainment" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/" target="_self">Entertainment</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Culture &amp; Arts" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/arts" target="_self">Culture &amp; Arts</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Media" data-subsec="entertainment" href="https://www.huffpost.com/news/media" target="_self">Media</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Celebrity" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/celebrity" target="_self">Celebrity</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="TV &amp; Film" data-subsec="entertainment" href="https://www.huffpost.com/entertainment/tv" target="_self">TV &amp; Film</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Life" data-subsec="life" href="https://www.huffpost.com/life/" target="_self">Life</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Style &amp; Beauty" data-subsec="life" href="https://www.huffpost.com/life/style" target="_self">Style &amp; Beauty</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Food &amp; Drink" data-subsec="life" href="https://www.huffpost.com/life/taste" target="_self">Food &amp; Drink</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Parenting" data-subsec="life" href="https://www.huffpost.com/life/parents" target="_self">Parenting</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Travel" data-subsec="life" href="https://www.huffpost.com/life/travel" target="_self">Travel</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Wellness" data-subsec="life" href="https://www.huffpost.com/life/healthy-living" target="_self">Wellness</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Relationships" data-subsec="life" href="https://www.huffpost.com/life/relationships" target="_self">Relationships</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Money" data-subsec="life" href="https://www.huffpost.com/life/money" target="_self">Money</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Home &amp; Living" data-subsec="life" href="https://www.huffpost.com/life/huffpost-home" target="_self">Home &amp; Living</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Work/Life" data-subsec="life" href="https://www.huffpost.com/life/worklife" target="_self">Work/Life</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Shopping" data-subsec="life" href="https://www.huffpost.com/life/topic/shopping" target="_self">Shopping</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Communities" data-subsec="communities" href="https://www.huffpost.com/voices/" target="_self">Communities</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Queer Voices" data-subsec="communities" href="https://www.huffpost.com/voices/queer-voices" target="_self">Queer Voices</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Women" data-subsec="communities" href="https://www.huffpost.com/voices/women" target="_self">Women</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Black Voices" data-subsec="communities" href="https://www.huffpost.com/voices/black-voices" target="_self">Black Voices</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Latino Voices" data-subsec="communities" href="https://www.huffpost.com/voices/latino-voices" target="_self">Latino Voices</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Asian Voices" data-subsec="communities" href="https://www.huffpost.com/voices/asian-voices" target="_self">Asian Voices</a>
</div>
<div class="left-nav__menu__group">
<span class="left-nav__menu__item left-nav__menu__item--heading">Special Projects</span>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Highline" data-subsec="special-projects" href="https://www.huffpost.com/highline" target="_self">Highline</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="HuffPost Personal" data-subsec="huffpost-personal" href="https://www.huffpost.com/section/huffpost-personal" target="_self">HuffPost Personal</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Video" data-subsec="video" href="https://www.huffpost.com/section/video" target="_self">Video</a>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Horoscopes" data-subsec="horoscopes" href="https://www.huffpost.com/horoscopes" target="_self">Horoscopes</a>
<span class="grid-placeholder"></span>
</div>
<div class="left-nav__menu__group">
<span class="left-nav__menu__item left-nav__menu__item--heading">From Our Partners</span>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Time To Shine" data-subsec="from-our-partners" href="https://www.huffpost.com/life/topic/time-to-shine" target="_self">Time To Shine</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="HerStory" data-subsec="from-our-partners" href="https://www.huffpost.com/voices/topic/herstory" target="_self">HerStory</a>
</div>
<div class="left-nav__menu__group">
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--heading yr-news-nav-link" data-name="Newsletters" data-subsec="newsletters" href="https://www.huffpost.com/newsletters" target="_self">Newsletters</a>
<span class="grid-placeholder"></span>
</div>
<div class="left-nav__menu__group">
<span class="left-nav__menu__item left-nav__menu__item--heading">International</span>
<span class="grid-placeholder"></span>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Australia" data-subsec="international" href="https://www.huffingtonpost.com.au/" target="_self">Australia</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Brazil" data-subsec="international" href="https://www.huffpostbrasil.com/" target="_self">Brazil</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Canada" data-subsec="international" href="https://www.huffingtonpost.ca/" target="_self">Canada</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="España" data-subsec="international" href="https://www.huffingtonpost.es" target="_self">España</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="France" data-subsec="international" href="https://www.huffingtonpost.fr" target="_self">France</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Ελλάδα (Greece)" data-subsec="international" href="https://www.huffingtonpost.gr" target="_self">Ελλάδα (Greece)</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="India" data-subsec="international" href="https://www.huffingtonpost.in" target="_self">India</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Italia" data-subsec="international" href="https://www.huffingtonpost.it" target="_self">Italia</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="日本 (Japan)" data-subsec="international" href="https://www.huffingtonpost.jp" target="_self">日本 (Japan)</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="한국 (Korea)" data-subsec="international" href="https://www.huffingtonpost.kr" target="_self">한국 (Korea)</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="Quebec" data-subsec="international" href="https://quebec.huffingtonpost.ca" target="_self">Quebec</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="U.K." data-subsec="international" href="https://www.huffingtonpost.co.uk/" target="_self">U.K.</a>
<a class="left-nav__menu__item left-nav__menu__item--linked left-nav__menu__item--link yr-news-nav-link" data-name="U.S." data-subsec="international" href="https://www.huffpost.com/" target="_self">U.S.</a>
</div>
</div>
<div class="left-nav__social">
<div class="social-buttons__title">Follow us</div>
<div class="social-buttons__icons">
<a class="social-buttons__icons__item social-buttons__icons__item--facebook yr-follow-item" data-button-name="facebook" href="https://facebook.com/HuffPost" target="_blank"></a>
<a class="social-buttons__icons__item social-buttons__icons__item--twitter yr-follow-item" data-button-name="twitter" href="https://twitter.com/HuffPost" target="_blank"></a>
<a class="social-buttons__icons__item social-buttons__icons__item--instagram yr-follow-item" data-button-name="instagram" href="https://instagram.com/HuffPost" target="_blank"></a>
</div>
</div>
<div class="left-nav__footer-links">
<a class="left-nav__footer__link" href="https://www.huffpost.com/static/user-agreement">Terms</a>
<span class="left-nav__footer-links__divider">|</span>
<a class="left-nav__footer__link" href="https://www.huffpost.com/static/privacy-policy">Privacy Policy</a>
</div>
<div class="left-nav__copyright">
Part of HuffPost News. ©2021 BuzzFeed, Inc. All rights reserved.
</div>
</div>
</div>


<div class="breaking-news-banner js-breaking-news-banner yr-breaking-news">
<div class="breaking-news-banner__fixed">BREAKING NEWS</div>
<a class="breaking-news-banner__text js-breaking-news-banner-text yr-breaking-news-link"></a>
<div class="breaking-news-banner__close js-breaking-news-banner-close yr-close yr-track"></div>
</div>

<div class="desktop-alerts-signup js-desktop-alerts-signup yr-desktop-alert-signup hidden">
<div class="desktop-alert-signup__inner">
<div class="desktop-alerts-center">
<div class="desktop-alerts-bell js-desktop-alerts-bell"></div>
<div class="desktop-alerts-banner-text js-desktop-alerts-banner-text">Tap here to turn on desktop notifications to get the news sent straight to you.</div>
</div>
<div class="desktop-alerts-close js-desktop-alerts-banner-close yr-close yr-track"></div>
</div>
</div>
<header class="header js-header " data-yaft-module="huffpost-top-nav">
<div class="header__content yr-masthead">
<div class="header__content-left js-header-content-left">
<div class="header__hamburger js-hamburger-button-container">
<button class="header__hamburger-link yr-hamburger-button yr-track js-hamburger-link"></button>
</div>
</div>
<div class="header__logo">
<a class="logo yr-logo-image" href="https://www.huffpost.com">
<img alt="HuffPost" class="header__logo__img" src="https://s.m.huffpost.com/assets/HuffPostHero-d783f680fb974e80346bdfa145131d058e596e1d32f791981875aa481702c770.svg">
</a>
</div>
<div class="header__content-right">
<div class="header__profile" id="global-header-profile-block">
<a class="header__profile__circle yr-modal-profile-circle-logged-out" href="https://login.huffpost.com/login?dest=https%3A%2F%2Fwww.huffpost.com%2Fentry%2Freactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1&amp;ncid=huffpost_articlenav_j8lokxbqp1w&amp;src=huffpost-nav-article"></a>
<a class="header__profile__log-in yr-modal-login" href="https://login.huffpost.com/login?dest=https%3A%2F%2Fwww.huffpost.com%2Fentry%2Freactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1&amp;ncid=huffpost_articlenav_j8lokxbqp1w&amp;src=huffpost-nav-article">Log In</a>
<a class="header__profile__subscription-button" href="https://www.huffpost.com/subscribe?ncid=huffpost_articlenav_j8lokxbqp1w">Join HuffPost Plus</a>
<script type="text/template">
<a class="header__profile__subscription-button {{__HP-SUBSCRIPTION-BUTTON-CLASSES__}}" href="https://www.huffpost.com/subscribe?ncid=huffpost_articlenav_j8lokxbqp1w">Join HuffPost Plus</a>
<a aria-label="Profile" class="header__profile__image-link yr-modal-profile-circle-logged-in" href="https://www.huffpost.com/member">
<img class="header__profile__image" src="{{__HP-USER-PROFILE-IMAGE-URL__}}">
</a>
</script>
</div>
</div>
</div>
</header>



<nav class="subnav js-subnav yr-subnav subnav--entry" id="nav">
<div class="subnav__content">
<div class="subnav__left">
<div class="subnav__hamburger js-hamburger-button-container">
<button class="subnav__hamburger-link yr-hamburger-button yr-track js-hamburger-link"></button>
</div>
<a class="subnav__logo__link" href="https://www.huffpost.com">
<img alt="HuffPost" class="subnav__logo--big js-non-entry-sticky" src="https://s.m.huffpost.com/assets/HuffPostHero-d783f680fb974e80346bdfa145131d058e596e1d32f791981875aa481702c770.svg">
<img alt="HuffPost" class="subnav__logo--small" src="https://s.m.huffpost.com/assets/H-icon-72fd5782b36a1a42ab82a4af65cbc6dd6ddc4d4a71190a91c5cfaab7c66fd836.svg">
</a>
</div>
<div class="nav-sticky__entry js-nav-entry hidden">
<div class="nav-sticky__item nav-sticky__title">Reactions To Trump’s Primetime Address</div>
<div class="nav-sticky__item nav-sticky__sharebar">
<div class="js-sharebar share-bar share-bar--nav-sticky share-bar--video" data-mobilepath="/us/entry/5c36122fe4b07c260cd0fdb1" data-sharingimage="https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000" data-sharingtitle="Reactions To Trump’s Primetime Address" data-sharingtweettext="Reactions+To+Trump%E2%80%99s+Primetime+Address" data-sharingurl="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" data-yaft-module="">
<ul class="share-bar__list yr-share">
<li class="bookmark share-bar__item" data-share-name="bookmark" data-type="bookmark">
<a aria-label="Share on bookmark" class="bookmark js-bookmark-button yr-no-track share-bar__item-link yr-share-item" data-share-name="bookmark" href="javascript:void(0);" role="button" target="_self"></a>
</li>

<li class="facebook share-bar__item" data-share-name="facebook" data-type="facebook">
<a aria-label="Share on facebook" class="facebook share-bar__item-link yr-share-item" data-share-name="facebook" href="https://facebook.com/share.php?u=https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" role="button" target="_blank"></a>
</li>

<li class="share-bar__item twitter" data-share-name="twitter" data-type="twitter">
<a aria-label="Share on twitter" class="share-bar__item-link twitter yr-share-item" data-share-name="twitter" href="https://twitter.com/share?text=Reactions+To+Trump%E2%80%99s+Primetime+Address&amp;url=https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1&amp;via=&amp;hashtags=" role="button" target="_blank"></a>
</li>

<li class="email share-bar__item" data-share-name="email" data-type="email">
<a aria-label="Email this article" class="email share-bar__item-link yr-share-item" data-share-name="email" href="mailto:?subject=Reactions%20To%20Trump%E2%80%99s%20Primetime%20Address&amp;body=Article: https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" role="button"></a>
</li>

<div class="share-bar__item js-sharebar-comments yr-share-item yr-track" data-share-name="comments_open" data-type="comments">
<div class="share-bar__comments__icon"></div>
</div>
</ul>
</div>

</div>
</div>
<div class="subnav__items js-subnav-items js-non-entry-sticky">
<a class="subnav__item yr-subnav-link" href="/news/">NEWS</a>
<a class="subnav__item yr-subnav-link" href="https://www.huffpost.com/feature/coronavirus">CORONAVIRUS</a>
<a class="subnav__item yr-subnav-link" href="/news/politics">POLITICS</a>
<a class="subnav__item yr-subnav-link" href="/entertainment/">ENTERTAINMENT</a>
<a class="subnav__item yr-subnav-link" href="/life/">LIFE</a>
<a class="subnav__item yr-subnav-link" href="/section/huffpost-personal">PERSONAL</a>
<a class="subnav__item yr-subnav-link" href="/life/topic/shopping">SHOPPING</a>
<a class="subnav__item subnav__item--current yr-subnav-link" href="/section/video">VIDEO</a>
</div>

<div class="editions-menu js-editions-menu yr-editions-menu">
<div class="editions-menu__list">
<div class="editions-menu__list__item current">U.S.</div>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="U.K." href="https://www.huffingtonpost.co.uk?country=UK">U.K.</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="España" href="https://www.huffingtonpost.es?country=ES">España</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="France" href="https://www.huffingtonpost.fr?country=FR">France</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Ελλάδα (Greece)" href="https://www.huffingtonpost.gr?country=GR">Ελλάδα (Greece)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="Italia" href="https://www.huffingtonpost.it?country=IT">Italia</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="日本 (Japan)" href="https://www.huffingtonpost.jp?country=JP">日本 (Japan)</a>
<a class="editions-menu__list__item yr-edition-item yr-track" data-edition="한국 (Korea)" href="https://www.huffingtonpost.kr?country=KR">한국 (Korea)</a>
</div>
</div>

<button aria-expanded="false" class="subnav__editions-menu__toggle closed js-edition-toggle yr-editions-button yr-track js-non-entry-sticky">U.S. Edition</button>
</div>
</nav>

<div class="header__placeholder js-header-placeholder"></div>

<div id="main" role="main">



<article class="entry-video">
<div class="js-entry entry-video__main" data-mobilepath="/us/entry/5c36122fe4b07c260cd0fdb1" data-sharingimage="https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000" data-sharingtitle="Reactions To Trump’s Primetime Address" data-sharingtweettext="Reactions+To+Trump%E2%80%99s+Primetime+Address" data-sharingurl="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" data-socialmessaging="{}" data-yaft-module="" id="5c36122fe4b07c260cd0fdb1" path="/us/entry/5c36122fe4b07c260cd0fdb1">
<div class="entry-video__main__inner js-entry-body js-entry-content">
<div class="entry-video__content yr-video-content">
<div class="entry-video__content__inner">
<div class="entry-video__content__label">NOW PLAYING</div>
<h1 class="entry-video__content__title js-headline">Reactions To Trump’s Primetime Address</h1>
<div class="entry-video__content__description">Here’s how pundits, politicians and comedians reacted to President Donald Trump’s address to the nation.</div>
<div class="js-horizontal-share">
<div class="js-sharebar share-bar share-bar--video" data-mobilepath="/us/entry/5c36122fe4b07c260cd0fdb1" data-sharingimage="https://img.huffingtonpost.com/asset/5c36122f3c00001406108cee.jpeg?ops=1778_1000" data-sharingtitle="Reactions To Trump’s Primetime Address" data-sharingtweettext="Reactions+To+Trump%E2%80%99s+Primetime+Address" data-sharingurl="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" data-yaft-module="">
<ul class="share-bar__list yr-share">
<li class="bookmark share-bar__item" data-share-name="bookmark" data-type="bookmark">
<a aria-label="Share on bookmark" class="bookmark js-bookmark-button yr-no-track share-bar__item-link yr-share-item" data-share-name="bookmark" href="javascript:void(0);" role="button" target="_self"></a>
</li>

<li class="facebook share-bar__item" data-share-name="facebook" data-type="facebook">
<a aria-label="Share on facebook" class="facebook share-bar__item-link yr-share-item" data-share-name="facebook" href="https://facebook.com/share.php?u=https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" role="button" target="_blank"></a>
</li>

<li class="share-bar__item twitter" data-share-name="twitter" data-type="twitter">
<a aria-label="Share on twitter" class="share-bar__item-link twitter yr-share-item" data-share-name="twitter" href="https://twitter.com/share?text=Reactions+To+Trump%E2%80%99s+Primetime+Address&amp;url=https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1&amp;via=&amp;hashtags=" role="button" target="_blank"></a>
</li>

<li class="pinterest share-bar__item" data-share-name="pinterest" data-type="pinterest">
<a aria-label="Share on pinterest" class="pinterest share-bar__item-link yr-share-item" data-share-name="pinterest" data-pin-custom="true" href="#" role="button" target="_blank"></a>
</li>

<li class="email share-bar__item" data-share-name="email" data-type="email">
<a aria-label="Email this article" class="email share-bar__item-link yr-share-item" data-share-name="email" href="mailto:?subject=Reactions%20To%20Trump%E2%80%99s%20Primetime%20Address&amp;body=Article: https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" role="button"></a>
</li>

<div class="share-bar__item js-sharebar-comments yr-share-item yr-track" data-share-name="comments_open" data-type="comments">
<div class="share-bar__comments__icon"></div>
</div>
</ul>
</div>

</div>
<div class="entry-video__content__ad">

</div>
</div>
</div>
<div class="entry-video__video">
<div class="entry-video__video__embed-code">
<div class="vdb_60b8e5bec5449357a7ad9b5260afc111dcf87c2cd2f5d8bf vdb_player" vdb_params="m.channel=us.hpmgvideo&amp;m.cms_tag=donald-trump%2Cpolitics%2Cmedia%2Chuffpost-news%2Cnews%2Cshutdown%2Cthe-wall&amp;m.fwkeyvalues=sponsorship%3DSPONSORSHIP_NAME&amp;m.fwsitesection=us.video&amp;m.hpid=5c36122fe4b07c260cd0fdb1&amp;m.loadingplaceholder=1&amp;m.onLoad=getVidiblePlayer&amp;m.page_type=bpage&amp;m.paid_p=the_huffington_post_584%3Dhpo%3A5c36122fe4b07c260cd0fdb1&amp;m.pct=video&amp;m.playertype=html&amp;m.pos=video&amp;m.pt=content&amp;m.ss=us.hpmgvideo&amp;m.zone3=video">
<script async src="https://delivery.vidible.tv/jsonp/pid=60b8e5bec5449357a7ad9b52/vid=5c36114f367f6d75d97b9eb5/60afc111dcf87c2cd2f5d8bf.js?m.channel=us.hpmgvideo&amp;m.cms_tag=donald-trump%2Cpolitics%2Cmedia%2Chuffpost-news%2Cnews%2Cshutdown%2Cthe-wall&amp;m.fwkeyvalues=sponsorship%3DSPONSORSHIP_NAME&amp;m.fwsitesection=us.video&amp;m.hpid=5c36122fe4b07c260cd0fdb1&amp;m.loadingplaceholder=1&amp;m.onLoad=getVidiblePlayer&amp;m.page_type=bpage&amp;m.paid_p=the_huffington_post_584%3Dhpo%3A5c36122fe4b07c260cd0fdb1&amp;m.pct=video&amp;m.playertype=html&amp;m.pos=video&amp;m.pt=content&amp;m.ss=us.hpmgvideo&amp;m.zone3=video"></script>
</div>

</div>
<div id="related-carousel"></div>
</div>
</div>
</div>
<div id="bottom-most-shared"></div>
</article>
<div class="inline-newsletter inline-newsletter--inlineWideBackgroundImage inline-newsletter--one-line inline-newsletter--the-morning-email">
<div class="inline-newsletter__image" style="background-image:url(&#39;https://img.huffingtonpost.com/asset/59e0f9e81500004800da1588.jpeg?ops=resize_1080_375&#39;);">
</div>
<div class="inline-newsletter__inner">
<div class="inline-newsletter__logo"></div>
<div class="inline-newsletter__content">
<div class="inline-newsletter__content__inner">
<div class="inline-newsletter__title">Subscribe to The Morning Email.</div>
<div class="inline-newsletter__description">Wake up to the day's most important news.</div>
</div>
<div class="inline-newsletter__signup">
<div class="newsletter-signup__success-message hidden"></div>
<form class="newsletter-signup__form yr-newsletter-form">
<input name="newsletter_source" type="hidden" value="mid-article desktop">
<input name="newsletter_provider" type="hidden" value="cm">
<input name="newsletter_id" type="hidden" value="6038192fd4a3595dbf2a5aac">
<div class="newsletter-signup__message__container hidden">
<div class="newsletter-signup__message"></div>
</div>
<div class="newsletter-signup__email">
<div class="newsletter-signup__email-input-container">
<input class="newsletter-signup__email-input" name="email_address" placeholder="address@email.com" title="Enter your email" type="text">
</div>
<div class="newsletter-signup__submit-container">
<input class="newsletter-signup__submit yr-signup-submit yr-track" type="submit" value="SUBSCRIBE">
<div class="newsletter-signup__success-check-icon hidden"></div>
<div class="progress-bar hidden">
<div class="progress-bar__first-half"></div>
<div class="progress-bar__second-half"></div>
</div>
</div>
</div>
</form>

</div>
</div>
</div>
</div>

<div class="below-entry js-below-entry">
<div class="below-entry__content" id="below-entry-desktop">
<div data-spotim-module="pitc" id="spot_pitc"></div>


<div class="advertisement below_entry_recirc" data-placement="below_entry_recirc" data-yaft-module="huffpost-below_entry_recirc">
<div id="readmo-8a537aa5c9194bcaadb078ce4a39eafd"></div>
</div>


</div>
</div>



<div class="below-entry">
<div class="js-bottom-trending" id="bottom-trending"></div>
</div>
<section class="entry__comments-pane js-comment-pane yr-comments-pane">
<div class="entry__comments-pane__close js-comment-close yr-close yr-track"></div>
<div class="comments" id="comments">
<div class="conversation-container" data-post-id="5c36122fe4b07c260cd0fdb1" data-spotim-module="conversation"></div>
</div>

</section>

<script async data-facebook-url="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" data-post-id="5c36122fe4b07c260cd0fdb1" data-post-url="https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1" data-spotim-autorun="false" data-spotim-module="spotim-launcher" id="comment-script"></script>
<script>
  waitForGlobal(function(){
    return HP.functions && HP.functions.launchSpotIM;
  }, function() {
    window.HP.functions.launchSpotIM();
  });
</script>


</div>
<div class="voting-toaster js-voting-toaster hidden yr-voting-toaster">
<div class="voting-toaster__inner">
<div class="voting-toaster__left">
<img alt="2020 Election" class="voting-toaster__image" src="https://img.huffingtonpost.com/asset/5d88f91b2100003200dab6d8.png">
<div class="voting-toaster__text">
<div class="voting-toaster__title">Today is National Voter Registration Day!</div>
<div class="voting-toaster__subtitle">We made it easy for you to exercise your right to vote!</div>
</div>
</div>
<a class="voting-toaster__button js-voting-toaster-button" href="https://huffpost.turbovote.org/" target="_blank">Register Now!</a>
<div class="voting-toaster__close js-voting-toaster-close yr-track yr-voting-toaster-close"></div>
</div>
</div>

<!-- Footer -->
<footer class="footer yr-footer">

<div class="advertisement leaderboard_footer" data-placement="leaderboard_footer" data-yaft-module="huffpost-leaderboard_footer">
<div id="ad_leaderboard_footer" class="ad_leaderboard_footer ad_wrapper_" style="display:table;margin:0 auto;padding:5px 0 15px;"><div id="ad-bottom-1" class="ad-leaderboard_footer ad-spot--gam ad-spot--gam-bottom-1"></div>
<script type="text/javascript">
  HPGam.cmd.push(function(){
		return HPGam.render("bottom-1", "leaderboard_footer", false);
  });
</script>
</div>
</div>


<script>
for (iframe of document.getElementsByTagName('iframe')) {
  source = iframe.getAttribute('src');
    if(source && source.match(/^(http|https):\/\/vid.me/)) {
      console.log(`removing ${source}`)
      iframe.remove();
    }
}
</script><!-- begin gemini flurry modulous insert -->
<script type="text/javascript">
  console.log("registering 699ae8fb-c80b-4445-901e-590f02388ad9 on target .js-bottom-most-shared .card.recirc__item:eq(1)");
  window.__yahooFlurry.register("699ae8fb-c80b-4445-901e-590f02388ad9");
  waitForGlobal(function() {
    return window.jQuery && window.jQuery(".js-bottom-most-shared .card.recirc__item:eq(1)").length > 0;
  }, function() {
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.adUnitCode = w_yahoo.adUnitCode || [];
    w_yahoo.adUnitCode.push("699ae8fb-c80b-4445-901e-590f02388ad9");
    var $yahooDiv = $("<div id=\"polar-gemini-most-shared\"></div>");
    if ( "replace" === "insertBefore" || "replace" === "replace" ) {
      $yahooDiv.insertBefore(".js-bottom-most-shared .card.recirc__item:eq(1)");
      if ( "replace" === "replace" ) {
        window.__yahooFlurry.addToCleanup("699ae8fb-c80b-4445-901e-590f02388ad9", "polar-gemini-most-shared", $(".js-bottom-most-shared .card.recirc__item:eq(1)")[0].outerHTML);
        $(".js-bottom-most-shared .card.recirc__item:eq(1)").remove(); 
      }
    } else {
      $yahooDiv.insertAfter(".js-bottom-most-shared .card.recirc__item:eq(1)");
    }
    window.__yahooFlurry.ready("699ae8fb-c80b-4445-901e-590f02388ad9");
  });
</script><!-- begin gemini flurry modulous insert -->
<script type="text/javascript">
  console.log("registering 275dc6d3-c9f8-495f-a25b-b315f711cd4a on target .js-bottom-trending .card.recirc__item:eq(1)");
  window.__yahooFlurry.register("275dc6d3-c9f8-495f-a25b-b315f711cd4a");
  waitForGlobal(function() {
    return window.jQuery && window.jQuery(".js-bottom-trending .card.recirc__item:eq(1)").length > 0;
  }, function() {
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.adUnitCode = w_yahoo.adUnitCode || [];
    w_yahoo.adUnitCode.push("275dc6d3-c9f8-495f-a25b-b315f711cd4a");
    var $yahooDiv = $("<div id=\"polar-gemini-whats-hot-2\"></div>");
    if ( "replace" === "insertBefore" || "replace" === "replace" ) {
      $yahooDiv.insertBefore(".js-bottom-trending .card.recirc__item:eq(1)");
      if ( "replace" === "replace" ) {
        window.__yahooFlurry.addToCleanup("275dc6d3-c9f8-495f-a25b-b315f711cd4a", "polar-gemini-whats-hot-2", $(".js-bottom-trending .card.recirc__item:eq(1)")[0].outerHTML);
        $(".js-bottom-trending .card.recirc__item:eq(1)").remove(); 
      }
    } else {
      $yahooDiv.insertAfter(".js-bottom-trending .card.recirc__item:eq(1)");
    }
    window.__yahooFlurry.ready("275dc6d3-c9f8-495f-a25b-b315f711cd4a");
  });
</script><!-- begin gemini flurry modulous insert -->
<script type="text/javascript">
  console.log("registering 5d21b62a-43dc-427d-a135-b583e70c1341 on target .js-bottom-trending .card.recirc__item:eq(5)");
  window.__yahooFlurry.register("5d21b62a-43dc-427d-a135-b583e70c1341");
  waitForGlobal(function() {
    return window.jQuery && window.jQuery(".js-bottom-trending .card.recirc__item:eq(5)").length > 0;
  }, function() {
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.adUnitCode = w_yahoo.adUnitCode || [];
    w_yahoo.adUnitCode.push("5d21b62a-43dc-427d-a135-b583e70c1341");
    var $yahooDiv = $("<div id=\"polar-gemini-whats-hot-7\"></div>");
    if ( "replace" === "insertBefore" || "replace" === "replace" ) {
      $yahooDiv.insertBefore(".js-bottom-trending .card.recirc__item:eq(5)");
      if ( "replace" === "replace" ) {
        window.__yahooFlurry.addToCleanup("5d21b62a-43dc-427d-a135-b583e70c1341", "polar-gemini-whats-hot-7", $(".js-bottom-trending .card.recirc__item:eq(5)")[0].outerHTML);
        $(".js-bottom-trending .card.recirc__item:eq(5)").remove(); 
      }
    } else {
      $yahooDiv.insertAfter(".js-bottom-trending .card.recirc__item:eq(5)");
    }
    window.__yahooFlurry.ready("5d21b62a-43dc-427d-a135-b583e70c1341");
  });
</script>
<script>
window.addEventListener('load', function() {
  var ref = document.getElementsByTagName("script")[0];
  var script = document.createElement("script");
  script.src = 'https://s.skimresources.com/js/38395X1559799.skimlinks.js';
  script.async = true;
  ref.parentNode.insertBefore(script, ref);
}, false);
</script>

<script type="text/javascript">
(function(){
  if (!!(window._modulous_disabled && window._modulous_disabled('publicgood'))) { 
    return; 
  }
	
  waitForGlobal(function(){
    var cambriaNodes = document.querySelectorAll(".js-main-content-list div.cli");
    var krakenNodes = document.querySelectorAll(".js-entry-text div.content-list-component");
    return !!(document.body && (cambriaNodes.length || krakenNodes.length));
  }, function() {
    var isLife = document.body.className.match(/life/) !== null;
    var placeholder = document.createElement('div');
    var hideCallback = function() {
      console.log('[PG]: no campaign match');
    };
    var showCallback;
    var nodes;
    placeholder.className = "pg-placeholder";
    placeholder.setAttribute('id', 'public-good-placeholder');
    if ( isLife ) {
      nodes = document.querySelectorAll(".js-main-content-list div.cli");
      showCallback = function() {
        console.log('[PG]: callback on life article');
        document.getElementById('public-good-placeholder').className = 'pg-placeholder active';
        //var div = document.querySelector("section.js-entry-content section.newsletter");
        //div.innerHTML = "";
        //document.getElementById('public-good-placeholder').className = 'pg-placeholder active';
      };
    } else {
      nodes = document.querySelectorAll(".js-entry-text div.content-list-component");
      showCallback = function() {
        console.log('[PG]: callback on news article');
        document.getElementById('public-good-placeholder').className = 'pg-placeholder active';
        //var div = document.querySelector("section.js-entry-inline-subscription-module");
        //div.innerHTML = "";
        //document.getElementById('public-good-placeholder').className = 'pg-placeholder active';
      };
    }
    var position = "mid";
    var targetDiv;
    if ( position === 'mid' ) {
      targetDiv = nodes[5];
    } else if ( position === 'bottom' ) {
      targetDiv = nodes[nodes.length - 1];
    }
    if ( !targetDiv || !targetDiv.parentNode ) {
      console.log('[PG]: could not find CLI at position \'mid\'');
    } else {
      targetDiv.parentNode.insertBefore(placeholder, targetDiv.nextSibling);
      var pgmOptions = {
        partnerId: "verizon-huffpost",
        onShow: function() {
          console.log('[PG]: show callback fired');
          showCallback();
        },
        onHide: function() {
          console.log('[PG]: hide callback fired');
          hideCallback();
        }
      };
      var script = document.createElement('script');
      script.async = true;
      script.onload = function() {
        pgmApi.create(document.getElementById("public-good-placeholder"), pgmOptions);
      };
      script.src = "https://assets.publicgood.com/pgm/v1/pgm-api.js";
      console.log('[PG]: loading PG scripts, position ' + position);
      document.head.appendChild(script);
    }
  });
})();
</script>
<!-- begin yahoo flurry footer bootstrap -->
<script type="text/javascript">
  waitForGlobal(function(){
    return window.__yahooFlurry.isReady();
  }, function() {
    if (!!(window._modulous_disabled && window._modulous_disabled('gemini'))) { return; }
    console.log("loading flurry yap.js");
    var w_yahoo = (top == self) ? window : window.top, d_yahoo = w_yahoo.document;
    w_yahoo.apiKey = "W56S5QZ4HX56YM9MRGXS";
    
    (function(){
      var script = d_yahoo.createElement("script");
      // script.async = true;
      if ( "" ) {
        script.src = "";
      } else {
        script.src = "https://s.yimg.com/av/yap/ga/yap.js";
      }
      script.onload = function() {
        console.log('yap.js loaded');
        console.log('adUnitCode', w_yahoo.adUnitCode);
      };
      d_yahoo.body.appendChild(script);
      window.console.log(w_yahoo.adUnitCode);
      window.__yahooFlurry.cleanup();
    })();
  });
</script>
<script
    type="text/javascript">window.readmoGatewayUrl='https:\/\/readmo.yahoo.com\/v1\/recommends';
    
       var infinite_scroll = 0;
    
    (window.readmo = window.readmo || []).push({
        section: '8a537aa5c9194bcaadb078ce4a39eafd',
        container: '#readmo-8a537aa5c9194bcaadb078ce4a39eafd',
        infinite:  infinite_scroll,
        params:{  }
    });
    !(function(d){
        var script = d.createElement("script");
        script.async = true;
        script.src = 'https:\/\/s.yimg.com\/dy\/ads\/readmo.js';
        d.body.appendChild(script);})(document);
</script>
<div class="footer__wrapper">
<div class="footer__top">
<div class="footer__logo">
<a class="yr-logo-image" href="https://www.huffpost.com">
<img alt="HuffPost" class="footer__img large" src="https://s.m.huffpost.com/assets/HuffPostHero-d783f680fb974e80346bdfa145131d058e596e1d32f791981875aa481702c770.svg">
<img alt="HuffPost" class="footer__img small" src="https://s.m.huffpost.com/assets/H-icon-72fd5782b36a1a42ab82a4af65cbc6dd6ddc4d4a71190a91c5cfaab7c66fd836.svg">
</a>
</div>
<ul class="footer__list sections">
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/news/" target="">News</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/news/politics" target="">Politics</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/entertainment/" target="">Entertainment</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/life/" target="">Life</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/voices/" target="">Communities</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/section/huffpost-personal" target="">HuffPost Personal</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/section/video" target="">Video</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/newsletters" target="">Newsletters</a>
</li>
</ul>
<ul class="footer__list corporate">
<li class="footer__item">
<a class="footer__link" href="/" target="">HuffPost</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/about-us" target="">About Us</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://advertise.buzzfeed.com/" target="_blank">Advertise</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/contact-us" target="">Contact Us</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/syndication" target="">RSS</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/faq" target="">FAQ</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.buzzfeed.com/about/jobs" target="_blank">Careers</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/archive" target="">Archive</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/user-agreement" target="">User Agreement</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/comment-policy" target="">Comment Policy</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/news/topic/press-room" target="">HuffPost Press Room</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/privacy-policy" target="">Privacy Policy</a>
</li>
<li class="footer__item">
<a class="footer__link" href="https://www.huffpost.com/static/huffpost-dmca-copyright-policy" target="">DMCA Policy</a>
</li>
<li class="footer__link"><li class="footer__item" style="max-width: 8.75rem"><div id="ccpa-link-container"></div></li></li></ul>
</div>
<div class="footer__bottom">
<div class="footer__copyright">Part of HuffPost News. ©2021 BuzzFeed, Inc. All rights reserved.</div>
<div class="footer__legal">The Huffington Post</div>
</div>
</div>
</footer>


<div class="yr-slideshow-desktop">

</div>
<div class="modal hidden yr-modal" id="modal">
<div class="modal__inner">
<div class="modal__close yr-close yr-track"></div>
<div class="modal__content yr-modal-body"></div>
</div>
</div>

<script>
  HP.functions.loadCSS('https://s.m.huffpost.com/assets/desktop-f0f60887c1af90ae6b70de4e66d13e3cfc442c0ca461dabc62d34a7ce69e0260.css');
</script>
<div class="tracking-data">
<script>
  window.comscore_data = {"c1":2,"c2":6723616,"c3":"","c4":"/us/entry/5c36122fe4b07c260cd0fdb1","c5":"video","c6":"","c15":"","options":{"url_append":"comscorekw=video"}};
  window.comscore_data.c4 = location.protocol+"//"+location.host+window.comscore_data.c4;
</script>

<script>
  window.yahooDotConfig = {"projectId":"10000","properties":{"pixelId":"428726","qstrings":{"site":"HuffPost","ec":null,"el":"video","ev":"donald-trump|politics|media|huffpost-news|news|shutdown|the-wall","pt":"content","pct":"video"}}};
</script>

<script>
  window.buzzfeed_cet_env = "prod";
  window.buzzfeed_cet_data = {"context_page_id":"5c36122fe4b07c260cd0fdb1","context_page_type":"buzz","destination":"huffpost","mode":"desktop","page_edition":"en-us"};
</script>

<script>
  window.permutive_data = {"publisher":"huffpost","platform":"web","edition":"us","type":"buzz","section":"video","bf_buzzid":"5c36122fe4b07c260cd0fdb1","title":"Reactions To Trump’s Primetime Address","description":null,"author":"huffpost-video","tags":["donald-trump","politics","media","huffpost-news","news","shutdown","the-wall"],"keywords":["Donald Trump","Politics","media","HuffPost News","News"," shutdown","the wall"]};
</script>


</div>
<div class="tracking">
<script>
  waitForGlobal(function() {
    return !!window.HP.modules.Tracky;
  }, function() {
    window.HP.modules.Tracky.comscore(window.comscore_data);
  })
</script>

<script>
  waitForGlobal(function() {
    return !!window.HP.modules.Tracky;
  }, function() {
    window.HP.modules.Tracky.yahooDot('page_view');
  });
</script>


</div>
<script>
  HP.modules.ads.slideshowLeft = "";
  HP.modules.ads.slideshowEndCard = "";
  HP.modules.ads.rightRailRecircCards = [];
  HP.modules.ads.rightRailVideoCards = [];
  HP.modules.ads.slideshowTop = "";
  HP.modules.ads.categoriesBottom = "";
  HP.modules.ads.rightRailSwap = "";
</script>
<script>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</script>

<script src="https://s.m.huffpost.com/assets/desktop-dc0299fbe979cf4472ab022aedbf46f63634ea5a57dbe0400f6d5853e089f724.js"></script>
<script>
  (function() {
    window.HP.params.entry = {
      id: "5c36122fe4b07c260cd0fdb1",
      tags: ["donald-trump", "politics", "media", "huffpost-news", "news", "shutdown", "the-wall"],
      title: "Reactions To Trump’s Primetime Address",
      excerpt: "",
      url: "https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1",
      canonicalUrl: "https://www.huffpost.com/entry/reactions-to-trumps-primetime-address_n_5c36122fe4b07c260cd0fdb1",
      author: "HuffPost Video",
      edition: "us",
      useCommentSSO: true,
      isAnyContributor: false
    };
    window.HP.params.preview = ("" === "true");
    window.HP.params.isWide = ("false" === "true");
    window.HP.params.isAthena = ("true" === "true");
    var isLong = 450 <= ($('.js-entry-body').height() / 2.5);
    window.HP.events.publish("entry_opened", {entry: document.querySelector('article'), isLong: isLong});
  }());
</script>

<script async src="https://apis.google.com/js/platform.js"></script>

<div class="tracking-init">
<!-- Permutive tracking -->
<script>
  !function(n,e,i){if(!n){n=n||{},window.permutive=n,n.q=[],n.config=i||{},n.config.apiKey=e,n.config.environment=n.config.environment||"production";for(var o=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],r=0;r<o.length;r++){var t=o[r];n[t]=function(e){return function(){var i=Array.prototype.slice.call(arguments,0);n.q.push({functionName:e,arguments:i})}}(t)}}}(window.permutive,"406b9ad8-2772-474f-82e6-774a332d9754",{});
  window.googletag=window.googletag||{},window.googletag.cmd=window.googletag.cmd||[],window.googletag.cmd.push(function(){if(0===window.googletag.pubads().getTargeting("permutive").length){var g=window.localStorage.getItem("_pdfps");window.googletag.pubads().setTargeting("permutive",g?JSON.parse(g):[])}});
  permutive.addon('web', {
      page: {
          meta: window.permutive_data
      }
  });
</script>
<script async src="https://a2a5c7f9-3fa0-4182-889a-15aa61acf59b.edge.permutive.app/d0aea23f-b86d-47b4-9d71-210104685824-web.js"></script>

<div id="vanitydiv" style="visibility:hidden; height: 0px;"></div>
<!-- Begin comScore Tag -->
<script>
  var prefix = (document.location.protocol == "https:" ? "https://sb" : "http://b");
  var script = document.createElement("script");
  script.src = prefix + ".scorecardresearch.com/beacon.js";
  script.async = true;
  script.onload = function() {
    if (window.__cmp) {
      window.__cmp('getVendorConsents', null, function(cmpData, cmpSuccess) {
        window.waitForGlobal('__uspapi', function() {
          window.__uspapi( 'getDoNotSell', 1, (uspData, uspSuccess) => {
            if ( cmpSuccess && cmpData && cmpData.gdprApplies && cmpData.vendorConsents ) {
              window.comscore_data.cs_ucfr = cmpData.vendorConsents[77] ? 1 : 0; // 77 is comscore's vendor id
            } else if ( uspSuccess && uspData && uspData.hasOwnProperty('doNotSell') ) {
              // "doNotSell === true" => user has opted out of letting us sell their info
              // "doNotSell === false" => user hasn't opted out
              window.comscore_data.cs_ucfr = uspData.doNotSell ? 0 : 1;
            }
            window.HP.events.publish('tracking_loaded_comscore');
          });
        });
      });
    } else {
      window.HP.events.publish('tracking_loaded_comscore');
    }
  };
  document.querySelector('.tracking').appendChild(script);
</script>
<noscript>
<img alt="" height="1" src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6723616&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cj=1" width="1">
</noscript>
<!-- End comScore Tag -->

<script>
  (function(d){
    var s = document.createElement('script');
    s.src='https://s.yimg.com/wi/ytc.js';
    s.async=true;
    s.onload = function() {
      window.HP.events.publish('tracking_loaded_yahoo_dot');
    };
    (d.getElementsByTagName('head')[0] ||
     d.getElementsByTagName('body')[0]).appendChild(s);
  })(document);
</script>

<script async defer src="https://s.yimg.com/ss/vops.js" type="text/javascript"></script>


</div>
<script>
  HP.functions.init();
  window.addEventListener('load', modulousQueue.runAll);
</script>

<script src="https://s.yimg.com/ss/rapid3.js" type="text/javascript"></script>
<script>
  window.rapidConfig = (function(){
    var rapidJson = {"spaceid":"1197803116","async_all_clicks":true,"tracked_mods":[],"nonanchor_track_class":"yr-track","accountGUID":null,"test_id":null,"rapid_noclick_resp":"yr-no-track","keys":{"st_sec":"us.hpmgvideo","pt":"content","pct":"video","paid":"the_huffington_post_584=hpo:5c36122fe4b07c260cd0fdb1","ver":"huffpostcms","p_sec":"other","p_subsec":"video","pstaid":"705ae435-99ce-3d4b-877a-c0d25d23f06f","layout":"default","pl4":"none","pl1":"none"}} || {};
    function getCookie(a) {
      var b = document.cookie.match('(^|;)\\s*' + a + '\\s*=\\s*([^;]+)');
      return b ? b.pop() : '';
    }
  
    return rapidJson;
  }());
  
  (function(){
    var AB = window.HP.modules.AB;
    window.rapidConfig.keys['pl3'] = AB.testMap();
  }());
  
  window.HP.functions.getProfile().then(function(profile) {
    if (!profile) {
      return;
    }
    window.rapidConfig.accountGUID = profile.guid;
    var subscription = profile.subscriptions.find(function(sub) {
      return sub.roles && sub.roles.indexOf('premium') > -1;
    });
    if (!subscription) {
      window.rapidConfig.keys.pl4 = 'basic';
      return;
    }
    switch (subscription.renewalPeriod) {
      case 'monthly':
        window.rapidConfig.keys.pl4 = 'premium-monthly';
      break;
      case 'yearly':
        window.rapidConfig.keys.pl4 = 'premium-annual';
      break;
    }
  }).then(function() {
    window.RapidInstance = new window.YAHOO.i13n.Rapid(window.rapidConfig);
  });
</script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1740781-82"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('set', {
    custom_map: {
      dimension1: 'pageType',
      dimension2: 'team',
      dimension3: 'tags',
      dimension4: 'edition',
      dimension5: 'department',
      dimension6: 'section',
      dimension7: 'author',
      dimension8: 'articleId',
      dimension9: 'publishDate',
      dimension10: 'platform',
      dimension11: 'loggedIn',
      dimension12: 'videoPresence',
      dimension13: 'originalEdition',
    },
  });
  var config = {"pageType":"content","team":"us_auto_video","tags":"donald-trump,politics,media,huffpost-news,news,shutdown,the-wall","edition":"us","department":"other","section":"video","author":"huffpost-video","articleId":"5c36122fe4b07c260cd0fdb1","publishDate":"2019-01-09T10:20:47-05:00","platform":"huffpostcms","videoPresence":"video_vidible_entrybody","originalEdition":"us"};
  HP.functions.getProfile().then(function(profile) {
    config.loggedIn = !!profile;
    gtag('set', config);
    gtag('config', 'UA-1740781-82', {
      page_title: "Reactions To Trump’s Primetime Address",
    });
  });
</script>

<!-- Facebook Pixel Code - kraken -->
<script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
      n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
      n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
      t.src=v;s=b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
  
  fbq('init', '1621685564716533');
  fbq('track', "PageView");
  
  (function () {
    'use strict';
    document.addEventListener('DOMContentLoaded', function () {
      document.body.addEventListener('click', function(event) {
        fbq('track', "Click");
      });
    });
  })();
</script>
<noscript>
<img height="1" src="https://www.facebook.com/tr?id=1621685564716533&amp;ev=PageView&amp;noscript=1" style="display:none" width="1">
</noscript>
<!-- End Facebook Pixel Code -->

<!--[if IE]>
<link rel="stylesheet" media="screen" href="https://s.m.huffpost.com/assets/ie-3d19a68f6b6f10d1a1f82dfae355483d08205e66b959611e370d50e21c19d841.css" />
<![endif]-->
</div>
</div>
</body>
</html>
